安装QT4.4.3后,使用CMAKE 编译还是提示我说我的qt是4.3的版本太老,求解!

编译安装或者制作Deb包
回复
funic
帖子: 44
注册时间: 2007-09-05 15:25
送出感谢: 0
接收感谢: 0

安装QT4.4.3后,使用CMAKE 编译还是提示我说我的qt是4.3的版本太老,求解!

#1

帖子 funic » 2008-09-30 14:51

CMake Error: The installed Qt version 4.3.0 is too old, at least version 4.4.1 is required

在那里更改CMAKE,找QT的路径,我已经把QT4.3 make uninstall 了。
头像
Cracky.Dream
帖子: 2
注册时间: 2008-09-30 15:07
送出感谢: 0
接收感谢: 0

Re: 安装QT4.4.3后,使用CMAKE 编译还是提示我说我的qt是4.3的版本太老,求解!

#2

帖子 Cracky.Dream » 2008-09-30 15:12

cmake是用qmake来判断Qt的版本和路径的,你检查一下path中的qmake是哪个版本的,不行的知把4.4.3的qmake ln一个到/usr/bin里面去。
funic
帖子: 44
注册时间: 2007-09-05 15:25
送出感谢: 0
接收感谢: 0

Re: 安装QT4.4.3后,使用CMAKE 编译还是提示我说我的qt是4.3的版本太老,求解!

#3

帖子 funic » 2008-09-30 15:32

是个办法,正在尝试。
funic
帖子: 44
注册时间: 2007-09-05 15:25
送出感谢: 0
接收感谢: 0

Re: 安装QT4.4.3后,使用CMAKE 编译还是提示我说我的qt是4.3的版本太老,求解!

#4

帖子 funic » 2008-09-30 16:26

这个可不是正解,现在我把/usr/lib/里的QT4.3的相关文件都删了,如何让CMAKE去/usr/local/Trolltech/Qt-4.4.3/找QMAKE
funic
帖子: 44
注册时间: 2007-09-05 15:25
送出感谢: 0
接收感谢: 0

Re: 安装QT4.4.3后,使用CMAKE 编译还是提示我说我的qt是4.3的版本太老,求解!

#5

帖子 funic » 2008-09-30 17:15

/usr/local/Trolltech/Qt-4.4.3/bin/加入path以后,在bash里可以用qmake了,但是还是在cmake 的时候出现qt qmake 找不到?单把qmake放到/usr/bin/里是不行的,还有/usr/lib/里也有qt的信息,难道要把/usr/local/Trolltech/Qt-4.4.3/的bin/和lib/ cp 到 /usr/里面的目录里面去?有什么方法可以配置cmake让他自己找到qmake啊!
moper874
帖子: 2
注册时间: 2009-05-19 18:21
送出感谢: 0
接收感谢: 0

Re: 安装QT4.4.3后,使用CMAKE 编译还是提示我说我的qt是4.3的版本太老,求解!

#6

帖子 moper874 » 2009-05-19 18:27

-- The installed Qt version 4.3.4 is too old, at least version 4.4.0

is required
CMake Error: Fatal error: QT (version >= 4.4.0) required. Cmake tries

to detect QT4 by searching for 'qmake' in your PATH.If you have QT4

installed, make sure qmake is found in your PATH. If you compiled QT4

yourself make sure your new qmake ist found _first_ in your PATH.
回复

回到 “编译或打包”