当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:编译出错
帖子发表于 : 2008-10-13 10:05 

注册: 2008-09-15 13:37
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
哪位高手帮忙看一下,我是照着论坛里的帖子配置的,但编译时出错如下:
include/asm/apic.h: 在函数‘native_apic_write’中:
include/asm/apic.h:65: 错误: 隐式声明函数‘fix_to_virt’
include/asm/apic.h:65: 错误: ‘FIX_APIC_BASE’未声明 (在此函数内第一次使用)
include/asm/apic.h:65: 错误: (即使在一个函数内多次出现,每个未声明的标识符在其
include/asm/apic.h:65: 错误: 所在的函数内也只报告一次。)
include/asm/apic.h: 在函数‘native_apic_write_atomic’中:
include/asm/apic.h:70: 错误: ‘FIX_APIC_BASE’未声明 (在此函数内第一次使用)
include/asm/apic.h: 在函数‘native_apic_read’中:
include/asm/apic.h:75: 错误: ‘FIX_APIC_BASE’未声明 (在此函数内第一次使用)
In file included from include/linux/smp.h:19,
from include/asm/desc.h:8,
from include/asm/elf.h:89,
from include/linux/elf.h:7,
from include/linux/module.h:14,
from include/linux/crypto.h:21,
from arch/x86/kernel/asm-offsets_32.c:7,
from arch/x86/kernel/asm-offsets.c:2:


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助:编译出错
帖子发表于 : 2008-10-17 21:17 
头像

注册: 2008-10-17 21:13
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
引用:
哪位高手帮忙看一下,我是照着论坛里的帖子配置的,但编译时出错如下:
include/asm/apic.h: 在函数‘native_apic_write’中:
include/asm/apic.h:65: 错误: 隐式声明函数‘fix_to_virt’
include/asm/apic.h:65: 错误: ‘FIX_APIC_BASE’未声明 (在此函数内第一次使用)
include/asm/apic.h:65: 错误: (即使在一个函数内多次出现,每个未声明的标识符在其
include/asm/apic.h:65: 错误: 所在的函数内也只报告一次。)
include/asm/apic.h: 在函数‘native_apic_write_atomic’中:
include/asm/apic.h:70: 错误: ‘FIX_APIC_BASE’未声明 (在此函数内第一次使用)
include/asm/apic.h: 在函数‘native_apic_read’中:
include/asm/apic.h:75: 错误: ‘FIX_APIC_BASE’未声明 (在此函数内第一次使用)


变量没有声明,把apic.h的60~80行发上来看看


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助:编译出错
帖子发表于 : 2008-10-18 22:17 

注册: 2008-09-15 13:37
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
a394474295 写道:
引用:
哪位高手帮忙看一下,我是照着论坛里的帖子配置的,但编译时出错如下:
include/asm/apic.h: 在函数‘native_apic_write’中:
include/asm/apic.h:65: 错误: 隐式声明函数‘fix_to_virt’
include/asm/apic.h:65: 错误: ‘FIX_APIC_BASE’未声明 (在此函数内第一次使用)
include/asm/apic.h:65: 错误: (即使在一个函数内多次出现,每个未声明的标识符在其
include/asm/apic.h:65: 错误: 所在的函数内也只报告一次。)
include/asm/apic.h: 在函数‘native_apic_write_atomic’中:
include/asm/apic.h:70: 错误: ‘FIX_APIC_BASE’未声明 (在此函数内第一次使用)
include/asm/apic.h: 在函数‘native_apic_read’中:
include/asm/apic.h:75: 错误: ‘FIX_APIC_BASE’未声明 (在此函数内第一次使用)


变量没有声明,把apic.h的60~80行发上来看看
谢谢,我想可能不用了。编译失败了2次外加一次kernel panic,我终于认识到自己还很菜。以后还是老老实实地从入门开始吧:-)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译