无法再次编译内核

编译安装或者制作Deb包
回复
头像
sgsdxzy
帖子: 430
注册时间: 2008-07-19 11:14
送出感谢: 4 次
接收感谢: 8 次

无法再次编译内核

#1

帖子 sgsdxzy » 2008-11-02 7:47

我第一次编译内核2.6.27.4,按照http://forum.ubuntu.org.cn/viewtopic.php?t=110461&highlight=的办法,成功了。当时配置文件没去改,编完200+MB,吓死我了……后来打算重编,可

代码: 全选

make mrproper
后执行

代码: 全选

sudo make-kpkg clean
显示

代码: 全选

exec make -f /usr/share/kernel-package/ruleset/minimal.mk clean 
/usr/share/kernel-package/ruleset/misc/version_vars.mk:161: *** Error. The version number 2.6.27.4Lightning VERSION=[2], PATCHLEVEL=[6], SUBLEVEL=[27], EXTRAVERSION=[.4], iatv=[], LOCALVERSION=[Lightning], GIT_VERSION=[] UTS_RELEASE_VERSION=[], KERNELRELEASE=[  ]. is not all lowercase. Since the version ends up in the package name of the kernel image package, this is a Debian policy violation, and the packaging system shall refuse to package the image. 。 停止。
再执行

代码: 全选

 sudo make-kpkg -initrd --initrd --append-to-version=gkr kernel_image
显示

代码: 全选

exec make -f /usr/share/kernel-package/ruleset/minimal.mk debian APPEND_TO_VERSION=gkr  INITRD=YES 
/usr/share/kernel-package/ruleset/misc/version_vars.mk:161: *** Error. The version number 2.6.27.4gkrLightning VERSION=[2], PATCHLEVEL=[6], SUBLEVEL=[27], EXTRAVERSION=[.4], iatv=[gkr], LOCALVERSION=[Lightning], GIT_VERSION=[] UTS_RELEASE_VERSION=[], KERNELRELEASE=[  ]. is not all lowercase. Since the version ends up in the package name of the kernel image package, this is a Debian policy violation, and the packaging system shall refuse to package the image. 。 停止。
Failed to create a ./debian directory: 没有该文件或目录 at /usr/bin/make-kpkg line 1096.
不能编译。我太菜,这是为什么啊?
回复

回到 “编译或打包”