编译2.6.28时如果想使用ext4要注意

编译安装或者制作Deb包
回复
rocky22
帖子: 684
注册时间: 2008-02-17 22:29
来自: 江苏
送出感谢: 0
接收感谢: 0

编译2.6.28时如果想使用ext4要注意

#1

帖子 rocky22 » 2008-12-29 16:13

编译2.6.28时,如果想使用ext4文件系统,要注意:必须要把下面两个选项选上,不然ext4分区无法挂载!(一般都说如果不需要支持2T以上的文件就不用选下面的选项,所以要注意)
在Enable Block Layer里:
Support for Large Block Devices (LBD)
Support for Large Single Files (LSF)
在.config文件里是下面两个参数:
CONFIG_LBD=y
CONFIG_LSF=y
头像
HuntXu
论坛版主
帖子: 5778
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

Re: 编译2.6.28时如果想使用ext4要注意

#2

帖子 HuntXu » 2008-12-29 17:16

可否给出相关的链接...因为不是很明白为什么非要选上这两项...
或者你可以看看是不是下面的这个问题:
viewtopic.php?f=77&t=177578
HUNT Unfortunately No Talent...
rocky22
帖子: 684
注册时间: 2008-02-17 22:29
来自: 江苏
送出感谢: 0
接收感谢: 0

Re: 编译2.6.28时如果想使用ext4要注意

#3

帖子 rocky22 » 2008-12-29 21:37

出错信息忘记保存了……
是在mount的时候出的提示信息,说不配置CONFIG_LSF是不能mount ext4的。
倒是没说CONFIG_LBD的事,但我觉得要选还是都选上比较好。
头像
苹果虫
帖子: 185
注册时间: 2008-08-25 18:57
送出感谢: 0
接收感谢: 0

Re: 编译2.6.28时如果想使用ext4要注意

#4

帖子 苹果虫 » 2008-12-30 22:57

我并没选上楼主说的这两项,也是能正常挂载EXT4分区的,只是/如果是EXT4的话无法引导
rocky22
帖子: 684
注册时间: 2008-02-17 22:29
来自: 江苏
送出感谢: 0
接收感谢: 0

Re: 编译2.6.28时如果想使用ext4要注意

#5

帖子 rocky22 » 2008-12-31 16:28

苹果虫 写了:我并没选上楼主说的这两项,也是能正常挂载EXT4分区的,只是/如果是EXT4的话无法引导
无法正常引导的话,参考一下这个:

代码: 全选

升级2.6.28内核后,/是ext4dev无法启动问题解决办法

ext4在2.6.28中正式启用,fstab的ext4dev也可以改为ext4了,但直接启动会提示ext4-fs not marks…..之类的错误。
这样就需要更改gurb或grub4dos的配置文件,添加rootfstype=ext4。
如:
kernel /boot/vmlinuz-2.6.28 root=UUID=xxxxx rootfstype=ext4 ro splash

这样就行可以解决了。
viewtopic.php?f=77&t=177578-
SquallATF
帖子: 13
注册时间: 2007-08-05 12:30
送出感谢: 0
接收感谢: 0

Re: 编译2.6.28时如果想使用ext4要注意

#6

帖子 SquallATF » 2009-01-06 10:41

我是wubi安装的,也没有选这两项
我把boot.disk改ext4了也可以引导添加loopfstype=ext4
kernel /boot/vmlinuz-2.6.28-4-athlon64 root=UUID=53D28F064112F244 loop=/ubuntu/disks/root.disk loopfstype=ext4 ro ROOTFLAGS=syncio quiet
还要改一下 /etc/fstab
/host/ubuntu/disks/root.disk / ext3 loop,errors=remount-ro 0 1
改为
/host/ubuntu/disks/root.disk / ext4 loop,errors=remount-ro 0 1
回复

回到 “编译或打包”