当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 自已编译2.6.28内核装不了ATI官方驱动的看这里
帖子发表于 : 2009-03-03 18:27 
头像

注册: 2008-08-25 18:57
帖子: 185
送出感谢: 0 次
接收感谢: 0 次
摘自GENTOO ati-drivers-8.582.ebuild,适用于ATI驱动9.2,把内核该关闭和该打开的选对。

代码:
if ! kernel_is 2 6; then
        eerror "Need a 2.6 kernel to compile against!"
        die "Need a 2.6 kernel to compile against!"
    fi

    if kernel_is ge 2 6 25 && linux_chkconfig_present PREEMPT_RCU; then
        die "${P} is not compatible with RCU Preemption (bug #223281), please disable it"
    fi

    if kernel_is ge 2 6 26 && ! linux_chkconfig_present UNUSED_SYMBOLS; then
            ewarn "You have to Enable unused/obsolete exported symbols in Kernel hacking section of kernel config for fglrx to load"
    fi

    if kernel_is ge 2 6 24 && ! linux_chkconfig_present PCI_LEGACY; then
        eerror "${P} requires support for pci_find_slot."
        die "${P} requires support for pci_find_slot."
    fi

    if ! linux_chkconfig_present MTRR; then
        ewarn "You don't have MTRR support enabled, the direct rendering will not work."
    fi

    if linux_chkconfig_builtin DRM; then
        ewarn "You have DRM support enabled builtin, the direct rendering will not work."
    fi

    if ! linux_chkconfig_present AGP && \
        ! linux_chkconfig_present PCIEPORTBUS; then
        ewarn "You need AGP and/or PCI Express support for direct rendering to work."
    fi

    if linux_chkconfig_present PARAVIRT; then
        eerror "The current ati-drivers don't compile when having"
        eerror "paravirtualization active due to GPL symbol export"
        eerror "restrictions."
        eerror "Please disable it:"
        eerror "    CONFIG_PARAVIRT=n"
        eerror "in /usr/src/linux/.config or"
        eerror "    Processor type and features -->"
        eerror "        [ ] Paravirtualization support (EXPERIMENTAL)"
        eerror "in 'menuconfig'"
        die "CONFIG_PARAVIRT enabled"
    fi

    if ! linux_chkconfig_present MAGIC_SYSRQ; then
        eerror "You need MAGIC_SYSRQ enabled in order to build ati-drivers"
        die "CONFIG_MAGIC_SYSRQ disabled"
    fi

    # Only support xorg-server >=1.5
    BASE_DIR="${S}/x740"

    if ! linux_chkconfig_present PCI_MSI; then
        eerror "You need PCI_MSI enabled in order to build ati-drivers"
        die "CONFIG_PCI_MSI disabled"
    fi


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译