FATAL: modprobe: Could not load /lib/modules/.../module.deb

编译安装或者制作Deb包
回复
头像
ptpt52
帖子: 717
注册时间: 2008-07-27 8:51
系统: Ubuntu/Windows
来自: 广西玉林|广东深圳
送出感谢: 1 次
接收感谢: 3 次
联系:

FATAL: modprobe: Could not load /lib/modules/.../module.deb

#1

帖子 ptpt52 » 2009-03-17 17:09

我自己编译的最新内核,启动时出现

代码: 全选

FATAL: modprobe: Could not load /lib/modules/2.6.28.7-goo/modules.dep
我检查过 /lib/modules/2.6.28.7-goo/modules.dep 存在。
虽然启动后运行正常,但不明白为什么有这个错误
我安照网上的说法
sudo update-initramfs -u
也不行

为什么啊,高手支招
fbsd4
帖子: 174
注册时间: 2007-03-19 8:07
送出感谢: 0
接收感谢: 0

Re: FATAL: modprobe: Could not load /lib/modules/.../module.deb

#2

帖子 fbsd4 » 2009-03-19 21:04

碰到同样错误,比较郁闷。
头像
qq126512306
帖子: 339
注册时间: 2007-08-31 9:17
送出感谢: 0
接收感谢: 0
联系:

Re: FATAL: modprobe: Could not load /lib/modules/.../module.deb

#3

帖子 qq126512306 » 2009-12-08 16:41

不知道LZ解决没有
Some people have reported that packing and unpacking the module does the trick, so after a short stint at the prompt I was hoping this would be fixed:

cd /boot
cp initrd.img-2.6.29.4 initrd-2.6.29.4.old (Just making a backup)
depmod -a
update-initramfs -k 2.6.29.4 -c
cd /tmp
gzip -dc /boot/initrd.img-2.6.29.4| cpio -id
touch lib/modules/2.6.29.4/modules.dep
find ./ | cpio -H newc -o > /boot/initrd.img-2.6.29.4.new
gzip /boot/initrd.img-2.6.29.4.new
cd /boot
mv initrd.img-2.6.29.4.new.gz initrd.img-2.6.29.4

Didn’t fix the problem unfortunately, but the I stumbled across a forum post over at Remote-Exploit and the following rather simple cammand fixed the whole shebang:

update-grub
希望有帮助! :em06 :em06 :em09
头像
ptpt52
帖子: 717
注册时间: 2008-07-27 8:51
系统: Ubuntu/Windows
来自: 广西玉林|广东深圳
送出感谢: 1 次
接收感谢: 3 次
联系:

Re: FATAL: modprobe: Could not load /lib/modules/.../module.deb

#4

帖子 ptpt52 » 2010-01-20 20:45

没解决,后来重新配置了内核,重新编译打包安装,又没有此问题了,不解。
走过去了也便有了路
http://www.ptpt52.com/
头像
amazingp35
帖子: 26
注册时间: 2009-02-19 10:30
送出感谢: 0
接收感谢: 0
联系:

Re: FATAL: modprobe: Could not load /lib/modules/.../module.deb

#5

帖子 amazingp35 » 2010-03-30 19:11

强大的人们 完全看不懂啊
rApe|NB
fanbih
帖子: 1
注册时间: 2009-11-01 10:21
送出感谢: 0
接收感谢: 0

Re: FATAL: modprobe: Could not load /lib/modules/.../module.

#6

帖子 fanbih » 2010-07-14 14:12

删掉了之前生成的/boot/initrd.img-2.6.28,执行

#cd /usr/src/linux

#update-initramfs –c –k 2.6.28

这样,重新在/boot下创建initrd.img-2.6.28,
sudo update-grub
重启后,进入了新内核,内核编译升级成功。
在Ubuntuserver9.10下测试成功
回复

回到 “编译或打包”