当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : FATAL: modprobe: Could not load /lib/modules/.../module.deb
帖子发表于 : 2009-03-17 17:09 
头像

注册: 2008-07-27 8:51
帖子: 711
地址: 广西玉林|广东深圳
系统: Ubuntu/Windows
送出感谢: 1
接收感谢: 3
我自己编译的最新内核,启动时出现
代码:
FATAL: modprobe: Could not load /lib/modules/2.6.28.7-goo/modules.dep

我检查过 /lib/modules/2.6.28.7-goo/modules.dep 存在。
虽然启动后运行正常,但不明白为什么有这个错误
我安照网上的说法
sudo update-initramfs -u
也不行

为什么啊,高手支招


页首
 用户资料  
 
2 楼 
 文章标题 : Re: FATAL: modprobe: Could not load /lib/modules/.../module.deb
帖子发表于 : 2009-03-19 21:04 

注册: 2007-03-19 8:07
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
碰到同样错误,比较郁闷。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: FATAL: modprobe: Could not load /lib/modules/.../module.deb
帖子发表于 : 2009-12-08 16:41 
头像

注册: 2007-08-31 9:17
帖子: 339
送出感谢: 0 次
接收感谢: 0 次
不知道LZ解决没有
引用:
Some people have reported that packing and unpacking the module does the trick, so after a short stint at the prompt I was hoping this would be fixed:

cd /boot
cp initrd.img-2.6.29.4 initrd-2.6.29.4.old (Just making a backup)
depmod -a
update-initramfs -k 2.6.29.4 -c
cd /tmp
gzip -dc /boot/initrd.img-2.6.29.4| cpio -id
touch lib/modules/2.6.29.4/modules.dep
find ./ | cpio -H newc -o > /boot/initrd.img-2.6.29.4.new
gzip /boot/initrd.img-2.6.29.4.new
cd /boot
mv initrd.img-2.6.29.4.new.gz initrd.img-2.6.29.4

Didn’t fix the problem unfortunately, but the I stumbled across a forum post over at Remote-Exploit and the following rather simple cammand fixed the whole shebang:

update-grub


希望有帮助! :em06 :em06 :em09


页首
 用户资料  
 
4 楼 
 文章标题 : Re: FATAL: modprobe: Could not load /lib/modules/.../module.deb
帖子发表于 : 2010-01-20 20:45 
头像

注册: 2008-07-27 8:51
帖子: 711
地址: 广西玉林|广东深圳
系统: Ubuntu/Windows
送出感谢: 1
接收感谢: 3
没解决,后来重新配置了内核,重新编译打包安装,又没有此问题了,不解。


_________________
走过去了也便有了路
http://www.ptpt52.com/


页首
 用户资料  
 
5 楼 
 文章标题 : Re: FATAL: modprobe: Could not load /lib/modules/.../module.deb
帖子发表于 : 2010-03-30 19:11 
头像

注册: 2009-02-19 10:30
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
强大的人们 完全看不懂啊


_________________
rApe|NB


页首
 用户资料  
 
6 楼 
 文章标题 : Re: FATAL: modprobe: Could not load /lib/modules/.../module.
帖子发表于 : 2010-07-14 14:12 

注册: 2009-11-01 10:21
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
删掉了之前生成的/boot/initrd.img-2.6.28,执行

#cd /usr/src/linux

#update-initramfs –c –k 2.6.28

这样,重新在/boot下创建initrd.img-2.6.28,
sudo update-grub
重启后,进入了新内核,内核编译升级成功。
在Ubuntuserver9.10下测试成功


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译