求助,依赖关系怎么解决

编译安装或者制作Deb包
回复
Nicholas_Lee
帖子: 18
注册时间: 2006-04-10 23:12
送出感谢: 0
接收感谢: 0

求助,依赖关系怎么解决

#1

帖子 Nicholas_Lee » 2006-07-21 23:01

正在读取软件包列表... 完成

正在分析软件包的依赖关系树... 完成

gcc 已经是最新的版本了。

您可能需要运行“apt-get -f install”来纠正下列错误:

下列的软件包有不能满足的依赖关系:

build-essential: 依赖: g++ (>= 4:4.0) 但却无法安装它

dpkg-dev: 依赖: binutils 但却无法安装它

gcc: 依赖: cpp (>= 4:4.0.3-1) 但却无法安装它

依赖: gcc-4.0 (>= 4.0.3) 但却无法安装它

libc6-dev: 依赖: linux-kernel-headers (>= 2.6.11.2-0) 但却无法安装它

E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个

解决办法)。

这是我在装GCC碰到的问题,怎么解决?
jiwmenn
帖子: 8
注册时间: 2006-05-02 22:12
送出感谢: 0
接收感谢: 0

#2

帖子 jiwmenn » 2006-07-27 21:36

我也遇到了同样的问题,但是我换了个源就可以安装成功了
不过还是请高手指导一下吧!
回复

回到 “编译或打包”