当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 编译安装conky-1.7.1.1时遇到的问题
帖子发表于 : 2009-06-12 11:43 

注册: 2009-01-13 10:30
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我编译的时候执行./configure命令,最后提示
configure: error: Package requirements (lua5.1 >= 5.1) were not met:

No package 'lua5.1' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LUA51_CFLAGS
and LUA51_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

然后安装了lua5.1了,但问题还是没有解决,然后我在新立得中安装conky想解决这个问题,但是还是找到lua5.1。

这是我的locate lua5.1的结果
/usr/bin/lua5.1
/usr/lib/liblua5.1.so.0
/usr/lib/liblua5.1.so.0.0.0
/usr/lib/debug/usr/bin/lua5.1
/usr/lib/debug/usr/lib/liblua5.1.so.0.0.0
/usr/share/doc/liblua5.1-0
/usr/share/doc/liblua5.1-0-dbg
/usr/share/doc/lua5.1
/usr/share/doc/liblua5.1-0/README.Debian.gz
/usr/share/doc/liblua5.1-0/changelog.Debian.gz
/usr/share/doc/liblua5.1-0/copyright
/usr/share/doc/liblua5.1-0-dbg/README.Debian.gz
/usr/share/doc/liblua5.1-0-dbg/changelog.Debian.gz
/usr/share/doc/liblua5.1-0-dbg/copyright
/usr/share/doc/lua5.1/README.Debian.gz
/usr/share/doc/lua5.1/changelog.Debian.gz
/usr/share/doc/lua5.1/copyright
/usr/share/man/man1/lua5.1.1.gz
/var/cache/apt/archives/liblua5.1-0-dbg_5.1.4-2_i386.deb
/var/cache/apt/archives/liblua5.1-0_5.1.4-2_i386.deb
/var/cache/apt/archives/lua5.1_5.1.4-2_i386.deb
/var/lib/dpkg/info/liblua5.1-0-dbg.list
/var/lib/dpkg/info/liblua5.1-0-dbg.md5sums
/var/lib/dpkg/info/liblua5.1-0.list
/var/lib/dpkg/info/liblua5.1-0.md5sums
/var/lib/dpkg/info/liblua5.1-0.postinst
/var/lib/dpkg/info/liblua5.1-0.postrm
/var/lib/dpkg/info/liblua5.1-0.shlibs
/var/lib/dpkg/info/lua5.1.list
/var/lib/dpkg/info/lua5.1.md5sums
/var/lib/dpkg/info/lua5.1.postinst
/var/lib/dpkg/info/lua5.1.prerm
我还缺少什么?谢谢大家。


附件:
文件注释: 这是我用的源码包 谢谢大家
conky-1.7.1.1.tar.bz2 [500.55 KiB]
被下载 21 次
页首
 用户资料  
 
2 楼 
 文章标题 : Re: 编译安装conky-1.7.1.1时遇到的问题
帖子发表于 : 2009-08-14 14:57 

注册: 2007-12-26 16:34
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
遇到同一情况了。。。同问


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 编译安装conky-1.7.1.1时遇到的问题
帖子发表于 : 2009-08-14 15:01 

注册: 2008-12-18 17:30
帖子: 221
送出感谢: 0 次
接收感谢: 1
lua的dev安装了没有


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 编译安装conky-1.7.1.1时遇到的问题
帖子发表于 : 2009-08-14 15:38 

注册: 2007-12-26 16:34
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
刚找到deb包的地址
http://www.getdeb.net/app/Conky


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 编译安装conky-1.7.1.1时遇到的问题
帖子发表于 : 2010-01-21 11:28 
头像

注册: 2008-06-22 13:38
帖子: 1627
地址: 武汉
送出感谢: 0 次
接收感谢: 0 次
今天也遇到这样的问题,lua已经安装了,但是它还是提示找不到


不知道怎么回事&&

求救

多谢


_________________
mint+gnome


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 编译安装conky-1.7.1.1时遇到的问题
帖子发表于 : 2010-11-18 23:44 
头像

注册: 2010-10-09 23:01
帖子: 7208
送出感谢: 8
接收感谢: 22
输入命令sudo apt-get install liblua5.1-0-dev


_________________
GitHub博客——稍微改了一下版面(于2012/8/23
新浪微博——话痨
新浪博客——伪技术博客
GitHub主页——充斥眼球的Common Lisp


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译