当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu9.10下安装x264编译时出错,帮看一下!
帖子发表于 : 2010-01-06 15:17 

注册: 2009-12-10 10:24
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
git clone git://git.videolan.org/x264.git
cd x264
./configure
代码:
Platform:   X86
System:     LINUX
asm:        yes
avs input:  no
mp4 output: no
pthread:    yes
debug:      no
gprof:      no
PIC:        no
shared:     no
visualize:  no

You can run 'make' or 'make fprofiled' now.

make后出现出下错误:
1
代码:
common/macroblock.c: In function ‘x264_macroblock_cache_init’:
common/macroblock.c:724: warning: ‘luma_plane_size’ may be used uninitialized in this function

2
代码:
common/common.c: In function ‘x264_param_parse’:
common/common.c:264: warning: ‘saveptr’ may be used uninitialized in this function

3.
代码:
encoder/analyse.c: In function ‘x264_intra_rd_refine’:
encoder/analyse.c:1138: warning: ‘pels_v[6]’ may be used uninitialized in this function
encoder/analyse.c:1138: warning: ‘pels_v[5]’ may be used uninitialized in this function
encoder/analyse.c:1138: warning: ‘pels_v[4]’ may be used uninitialized in this function
encoder/analyse.c:1138: warning: ‘pels_v[3]’ may be used uninitialized in this function
encoder/analyse.c:1138: warning: ‘pels_v[2]’ may be used uninitialized in this function


4
代码:
encoder/encoder.c: In function ‘x264_slice_write’:
encoder/encoder.c:1615: warning: ‘bs_bak.p_start’ may be used uninitialized in this function
encoder/encoder.c:1615: warning: ‘bs_bak.p’ may be used uninitialized in this function
encoder/encoder.c:1615: warning: ‘bs_bak.p_end’ may be used uninitialized in this function
encoder/encoder.c:1615: warning: ‘bs_bak.cur_bits’ may be used uninitialized in this function
encoder/encoder.c:1615: warning: ‘bs_bak.i_left’ may be used uninitialized in this function
encoder/encoder.c:1615: warning: ‘bs_bak.i_bits_encoded’ may be used uninitialized in this function

各位帮看一下这是什么原因?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu9.10下安装x264编译时出错,帮看一下!
帖子发表于 : 2010-01-06 15:21 
头像

注册: 2007-08-05 17:40
帖子: 4979
送出感谢: 0 次
接收感谢: 6
warning没有什么问题吧,error才是问题。


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu9.10下安装x264编译时出错,帮看一下!
帖子发表于 : 2010-01-06 15:23 

注册: 2009-12-10 10:24
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
warning没问题?,那我试试安装一下,我怕一会影响安装ffmpeg

谢谢!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译