如何让编译打包后安装的软件不被系统自动升级(已解决)

编译安装或者制作Deb包
回复
人在井天
帖子: 1081
注册时间: 2009-04-29 21:22
送出感谢: 0
接收感谢: 1 次

如何让编译打包后安装的软件不被系统自动升级(已解决)

#1

帖子 人在井天 » 2010-01-23 10:54

在ubuntu9.10系统上,编译了pidgin2.6.5,用sudo checkinstall命令打包安装后,在使用sudo apt-get dist-upgrade命令的时候,自己所打包安装的pidgin2.6.5总是被自动升级为了pidgin2.6.2,其实是降级了。为什么系统不能识别自己所打包的版本?在checkinstall的时候需要着重修改一下什么?我全用的默认。我也注意到了,默认的版本号就是:2.6.5
上次由 人在井天 在 2010-01-23 14:05,总共编辑 1 次。
人在井天
帖子: 1081
注册时间: 2009-04-29 21:22
送出感谢: 0
接收感谢: 1 次

Re: 如何让编译打包后安装的软件不被系统自动升级

#2

帖子 人在井天 » 2010-01-23 10:58

control文件里面的内容是:

代码: 全选

Package: pidgin
Priority: extra
Section: checkinstall
Installed-Size: 32428
Maintainer: root@pzye-desktop
Architecture: amd64
Version: 2.6.5-1
Depends: 
Provides: pidgin
Description: pidgin2.6.5
人在井天
帖子: 1081
注册时间: 2009-04-29 21:22
送出感谢: 0
接收感谢: 1 次

Re: 如何让编译打包后安装的软件不被系统自动升级

#3

帖子 人在井天 » 2010-01-23 14:05

晕,把Version: 2.6.5-1改成Version: 1:2.6.5-1ubuntu7.1,问题解决。
回复

回到 “编译或打包”