编译bmpx0.30遇到的问题

编译安装或者制作Deb包
回复
头像
latteye
帖子: 218
注册时间: 2006-08-13 2:04
送出感谢: 0
接收感谢: 0

编译bmpx0.30遇到的问题

#1

帖子 latteye » 2006-09-25 13:19

求救
由于官方没有给出0.30的ubuntu deb,所以我打算自己编译。
安装官方网页设置好deb和src源。
apt-get build-dep bmpx
安装好编译环境,并且已经update到最新。
可是在./configure的时候提示:

checking for GST... configure: error: Package requirements (gstreamer-0.10 >= 0.10.7 gstreamer-base-0.10 >= 0.10.7) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the GST_CFLAGS and GST_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.

而事实上,我有如下的包都已经安装到了0.10.7版本
gstreamer0.10-alsa
gstreamer0.10-gnomevfs
gstreamer0.10-plugins-base
gstreamer0.10-plugins-base-apps
gstreamer0.10-plugins-base-dbg
gstreamer0.10-plugins-base-doc
gstreamer0.10-x
libgstreamer-plugins-base0.10-0
libgstreamer-plugins-base0.10-dev

在新利得里面查看,虽然包名为0.10,但是已经安装版本是0.10.7。
不过我的lib目录下的目录也是gstreamer0.10而非0.10.7。
现在不知道如何解决了。
判断并不是没有发现库文件而是没有正确识别版本。所以感觉设置环境变量没效果吧……
回复

回到 “编译或打包”