有没可能弄一个GLIBC 2.3X+GCC 3.X为基础的Ubuntu 10.04?

编译安装或者制作Deb包
回复
swgchlry
帖子: 7
注册时间: 2010-10-07 10:57
送出感谢: 0
接收感谢: 0

有没可能弄一个GLIBC 2.3X+GCC 3.X为基础的Ubuntu 10.04?

#1

帖子 swgchlry » 2010-10-07 11:04

Ubuntu 10.04的GCC和GLIBC版本太高了,即使再怎么漂亮,企业级软件不认,也不敢用,所以冒出了如题的想法,不知道难度有多大,因为执行GLIBC的系统降级太难了。
levee
帖子: 3030
注册时间: 2009-10-03 23:31
送出感谢: 0
接收感谢: 13 次

Re: 有没可能弄一个GLIBC 2.3X+GCC 3.X为基础的Ubuntu 10.04?

#2

帖子 levee » 2010-10-07 14:01

企业级用户建议使用debian stable,RHEL(CentOS),ubuntu主要是针对个人桌面的。
swgchlry
帖子: 7
注册时间: 2010-10-07 10:57
送出感谢: 0
接收感谢: 0

Re: 有没可能弄一个GLIBC 2.3X+GCC 3.X为基础的Ubuntu 10.04?

#3

帖子 swgchlry » 2010-10-07 20:09

levee 写了:企业级用户建议使用debian stable,RHEL(CentOS),ubuntu主要是针对个人桌面的。
我想在本本上装,另外即使是RHEL5以上的,照样存在GLIBC的问题,这里的关键不是用哪个系统,而是GLIBC
rediscover
帖子: 3173
注册时间: 2010-01-13 23:26
送出感谢: 0
接收感谢: 12 次

Re: 有没可能弄一个GLIBC 2.3X+GCC 3.X为基础的Ubuntu 10.04?

#4

帖子 rediscover » 2010-10-10 15:39

那你该找你的软件提供商,看他们的意见。既然卖Linux软件,就是要花点价钱的,也要告诉你他们的软件能在什么上跑,不能在什么上跑。
你可以自己搞套工具链然后重新编译这个系统,那样就可以了。
Here I am.
Ubuntu 桌面培训 - 全中文官方文档,含汉化截图,提供PDF
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

Re: 有没可能弄一个GLIBC 2.3X+GCC 3.X为基础的Ubuntu 10.04?

#5

帖子 jarryson » 2010-10-10 16:57

你将工具链都降级了,你整个系统都需要重新编译。升级的话以为向下兼容所以问题不大,但是降级。。。

在本子上需要这么高的“企业级别稳定”性吗
头像
fanhe
帖子: 2357
注册时间: 2007-03-24 23:45
送出感谢: 0
接收感谢: 9 次

Re: 有没可能弄一个GLIBC 2.3X+GCC 3.X为基础的Ubuntu 10.04?

#6

帖子 fanhe » 2010-10-18 1:44

自己做一个低版本的库合计
然后自己做个脚本,把运行那些需要低级库的软件全部链接到旧的库

如果整个系统都换了低版本的库的话,尤其是基础库,那整个系统都崩了,除非你重新编译整个系统
回复

回到 “编译或打包”