当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 手动编译升级某软件会破坏后续升级线路吗?
帖子发表于 : 2010-10-19 22:33 

注册: 2009-10-17 16:02
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
比如刚装了Ubuntu 10.10,然后用apt-get安装好apache2.2.16/php5.3.3/mysq5.1.49
现在想将apache升级到2.2.17,一般是用手工编译的方法升级吧?
那么这样做会不会破坏升级连贯性呢?比如以后更新源中有apache2.2.18的包,用apt-get会不会升级不到?

官方更新源多久才会制作新的包啊?mysql好像已经出5.1.51好多天了。
纠结,是自己动手,还是等官方更新。请过来人指导一下,谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 手动编译升级某软件会破坏后续升级线路吗?
帖子发表于 : 2010-10-20 3:28 

注册: 2007-10-14 13:22
帖子: 178
送出感谢: 0 次
接收感谢: 0 次
你最好自己編譯打成deb包安裝,不要簡單地 make, make install
apt-get source apache
然後把源碼裏面的 debian 文件夾拷貝到解壓開的新版源碼目錄裏面去,修改 changelog ,最後 debuild 即可。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 手动编译升级某软件会破坏后续升级线路吗?
帖子发表于 : 2010-10-20 10:51 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
如果你需要架站的话,一般没有必要升级 apache,因为没有什么必须的理由让你这么做。

另外自己编译的通常是在不同的目录,跟系统的那个没有关系。两者完全独立,


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译