GLIB 2.0.0 or better is required.

编译安装或者制作Deb包
回复
hnlzj
帖子: 2
注册时间: 2010-11-29 21:48
送出感谢: 0
接收感谢: 0

GLIB 2.0.0 or better is required.

#1

帖子 hnlzj » 2010-11-29 22:04

配置atk的时候出现:
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.26.0, but GLIB (2.20.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

怎么做?
glib-2.26刚装上的。
hnlzj
帖子: 2
注册时间: 2010-11-29 21:48
送出感谢: 0
接收感谢: 0

Re: GLIB 2.0.0 or better is required.

#2

帖子 hnlzj » 2010-11-30 10:22

解决了,方法:
reinstall pango and glib this way

代码: 全选

sudo ./configure --prefix=/usr
sudo make
sudo make install
出处http://ubuntuforums.org/showthread.php?t=1066573
回复

回到 “编译或打包”