[问题]如何限定软件包的版本,避开系统自动升级?

编译安装或者制作Deb包
回复
头像
xiaosilent
帖子: 513
注册时间: 2006-05-09 9:59
来自: 四川成都
送出感谢: 1 次
接收感谢: 0
联系:

[问题]如何限定软件包的版本,避开系统自动升级?

#1

帖子 xiaosilent » 2006-12-18 15:52

我自己编译了fcitx gaim 等等好几个软件包,而且都是打包成 .deb 格式的。

但是,系统一直提示说我的这些软件包可以升级了,要我去升级,而我又不想去升级。虽然每次升级的时候都 “强制版本” 一次,但是,感觉又点麻烦呢,有不有什么一劳永逸的办法呢?把版本限定死,永不升级。

请大家指点一二,小弟在此先行谢过。
tyfj
帖子: 48
注册时间: 2007-06-05 20:11
送出感谢: 0
接收感谢: 0

#2

帖子 tyfj » 2007-08-15 0:06

试试 "锁定版本“ 可以吗?
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#3

帖子 xiechy » 2007-08-15 13:35

代码: 全选

sudo echo -e "PACKAGE: mplayer\nPin: version 1.0~rc1ubuntu10\nPin-Priority: 1001" >> /etc/apt/preferences
超过1000的Pin永远不会被替代。
回复

回到 “编译或打包”