在6。10编译的程序如何用于6。06?(glibc版本不同)

编译安装或者制作Deb包
回复
kotter
帖子: 2
注册时间: 2007-01-31 1:10
送出感谢: 0
接收感谢: 0

在6。10编译的程序如何用于6。06?(glibc版本不同)

#1

帖子 kotter » 2007-01-31 1:15

我在6。10下用checkinstall打包gaim,但是不能用在6。06上,提示需要glsibc2.4(ubuntu6.10是这个版本),ubuntu6。06是glibc2。36,结果不能运行,请问各位大侠如何做才可以通用?
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#2

帖子 xiechy » 2007-02-05 20:54

在6.06下编译~~
如果你没有6.06的环境,可以debootstrap一个dapper的环境,然后chroot进去。
我就是在feisty下面编译debian的sid的,一个道理。
kotter
帖子: 2
注册时间: 2007-01-31 1:10
送出感谢: 0
接收感谢: 0

谢谢xiechy的答案

#3

帖子 kotter » 2007-02-05 22:07

这样估计可行,我试一试,先谢谢了。
其它大仙们有没有更好的办法?
回复

回到 “编译或打包”