当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]编译时 error: C compiler cannot create executables
帖子发表于 : 2007-03-01 10:16 

注册: 2007-02-16 11:10
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
初步在网上搜索,建议安装build-essential
在安装时,报错了:
build-essential: Depends: libc6-dev but it is not going to be installed or
libc-dev
Depends: g++ (>= 4:4.0) but it is not going to be installed

尝试安装libc6-dev , g++
libc6-dev: Depends: libc6 (= 2.3.6-0ubuntu20.4) but 2.4-1ubuntu12 is to be installed
g++: Depends: g++-4.0 (>= 4.0.3) but it is not going to be installed

没辙了
我的系统是:Linux ubuntu 2.6.17-10-server #2 SMP Fri Oct 13 18:47:26 UTC 2006 i686 GNU/Linux

希望有好的建议,谢谢


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-03-27 23:45 

注册: 2007-02-09 0:14
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
顶一下,我也碰到这个问题.
romeo@romeo-laptop:~$ uname -a
Linux romeo-laptop 2.6.17-10-generic #2 SMP Fri Oct 13 18:45:35 UTC 2006 i686 GNU/Linux


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-02 21:35 

注册: 2007-04-02 21:09
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
把源选对,注意加上 edgy-updates, 再不行把edgy-security,proposed也加上
然后试试用暴力点的 aptitude install
apt-get比较腼腆,经常碰到不一致的版本就抓瞎了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译