安装g++时遇到的问题,帮帮忙阿

编译安装或者制作Deb包
回复
ccrt
帖子: 16
注册时间: 2007-03-20 10:18
送出感谢: 0
接收感谢: 0

安装g++时遇到的问题,帮帮忙阿

#1

帖子 ccrt » 2007-03-20 23:35

ccrt@ccrt:~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.0) 但是它将不会被安装
E: 无法安装的软件包
ccrt@ccrt:~$


搜遍了整个论坛都没有解决的办法,官方英文说明里也没提到这个问题。
还有,在安装nvidia驱动时遇到同样的问题,后来无奈的降低了内核版本才解决,这次是怎么样都不行了。
libc6-dev版本太高,又没办法强制版本,重装了n次n次都无法解决,不知道还有没人遇到过这个问题,指点一下。
编程无法进行,ubuntu变成娱乐工具了,郁闷!
meladet
帖子: 18
注册时间: 2006-08-27 19:32
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 meladet » 2007-03-27 12:41

是阿。 我也遇到这个问题。 死活解决不了 。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 BigSnake.NET » 2007-03-27 13:00

sudo aptitude install build-essential
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
永恒不永恒
帖子: 124
注册时间: 2007-03-17 18:57
来自: 广东广州
送出感谢: 0
接收感谢: 0

#4

帖子 永恒不永恒 » 2007-04-27 19:22

从你这个来看,应该是在安装build-essential之前,必须安装以下三个软件包:
libc6-dev和libc-dev以及g++ 4.0
但是你没有安装这3个软件包。所以无法继续安装。
你要先安装这3个软件包再安装build-essential
我用ubuntu 6.06,gnome桌面~
结果装个qBittorrent搞不定,
然后就换到ubuntu 7.04了..同样是gnome桌面~
定制才是王道!
muyouyou
帖子: 3
注册时间: 2008-08-25 19:35
送出感谢: 0
接收感谢: 0

Re: 安装g++时遇到的问题,帮帮忙阿

#5

帖子 muyouyou » 2008-09-25 14:47

我也是这个问题,有人解决了没?
头像
Ur@nus
帖子: 622
注册时间: 2006-12-01 23:02
送出感谢: 0
接收感谢: 0

Re: 安装g++时遇到的问题,帮帮忙阿

#6

帖子 Ur@nus » 2008-10-12 20:52

这个有可能是循环依赖导致的。可以下载deb包然后忽略依赖安装,再apt-get install 需要的软件
sudo dpkg -i --ignore-depends=libstdc++6-4.1-dev g++-4.1_4.1.2-0ubuntu4_i386.deb
sudo dpkg -i --ignore-depends=g++-4.1 libstdc++6-4.1-dev_4.1.2-0ubuntu4_i386.deb
fatangel
帖子: 13
注册时间: 2008-08-28 22:04
送出感谢: 0
接收感谢: 0

Re: 安装g++时遇到的问题,帮帮忙阿

#7

帖子 fatangel » 2008-10-18 10:26

我也碰到这个问题,楼主搞掂了没有,把经验分享一下啊!
canjian
帖子: 4
注册时间: 2007-12-28 19:56
送出感谢: 0
接收感谢: 0

Re: 安装g++时遇到的问题,帮帮忙阿

#8

帖子 canjian » 2008-11-02 16:56

3楼有效
ijkh007
帖子: 13
注册时间: 2008-11-02 21:23
送出感谢: 0
接收感谢: 0

Re: 安装g++时遇到的问题,帮帮忙阿

#9

帖子 ijkh007 » 2008-11-04 21:13

6楼的方法成功。
sudo dpkg -i --force-depends libstdc++6-4.1-dev g++-4.1_4.1.2-0ubuntu4_i386.deb
minicatjimmy
帖子: 133
注册时间: 2008-09-05 11:52
送出感谢: 0
接收感谢: 0

Re: 安装g++时遇到的问题,帮帮忙阿

#10

帖子 minicatjimmy » 2008-11-06 17:27

3楼的有效,另外这个问题一般都发生在安装nvidia原厂驱动的时候把~ 貌似原厂使用的g++的版本是4.2,而我们机器里已经是4.3了……一定要降级,不然很危险,我n久前就死过一次了,很惨
ace1346
帖子: 17
注册时间: 2008-05-19 11:34
送出感谢: 0
接收感谢: 0

Re: 安装g++时遇到的问题,帮帮忙阿

#11

帖子 ace1346 » 2008-11-26 11:57

3楼正解
回复

回到 “编译或打包”