[问题]内核降级启动不了了

编译安装或者制作Deb包
回复
Feb29
帖子: 8
注册时间: 2007-04-02 21:09
送出感谢: 0
接收感谢: 0
联系:

[问题]内核降级启动不了了

#1

帖子 Feb29 » 2007-04-02 21:25

我原来用dapper,同时还有一个kernel-2.4.26以备不时之需
日前将dapper升级到edgy,回头突然发现2.4内核启动不了了:

FATAL: kernel too old
kernel panic: Attempted to kill init!
然后只能关电源。

我有两个疑点:
1.升级时把modutils漏掉了。意识到这一点时我重装了modutils,
因为2.4内核用modutils而2.6内核用module-init-tools,
但内核启动的时候是怎么知道选哪个 module-tools 呢?这个配置有什么讲究?
2.据说2.4不支持udev, 但我怎么知道此时正跑着的 2.6 内核是用 udev 的?
我要是把 /dev 目录删除了万一 2.6也起不来了岂不是很惨
如果为 2.4 重建 /dev 有什么要求?

请大侠出手相助啊
回复

回到 “编译或打包”