a patch can not use?who can do it

编译安装或者制作Deb包
回复
yubinalice
帖子: 112
注册时间: 2015-12-23 16:20
系统: ubuntu 16.04
送出感谢: 1 次
接收感谢: 0

a patch can not use?who can do it

#1

帖子 yubinalice » 2016-12-10 23:44

today the chinese input is broken.
so use english to say it.
there i download a patch to let the mupdf can continuous the PDF file that the original source cannot.
there is the patch
i use

patch -p1 < filepath

but it can not ok.
who know how to use it.

there is the return of the command :

patch -p1 < ./mupdf-continuous-scrolling.patch
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git a/apps/pdfapp.c b/apps/pdfapp.c
|index 52bb4c4..dbe32f3 100644
|--- a/apps/pdfapp.c
|+++ b/apps/pdfapp.c
--------------------------
File to patch:

ok,
i do not know which file to patch
so
who know and tell me below.

thank you very much.
附件
mupdf-continuous-scrolling.patch.txt
the path of mupdf can continuous
(1.64 KiB) 下载 20 次
poloshiao
论坛版主
帖子: 18236
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1947 次

Re: a patch can not use?who can do it

#2

帖子 poloshiao » 2016-12-11 7:32

https://www.cyberciti.biz/faq/appy-patc ... h-command/
HowTo Apply a Patch File To My Linux / UNIX Source Code
回复

回到 “编译或打包”