当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教如何解决编译pcsc时候出现c编译器不作用
帖子发表于 : 2017-01-10 17:11 

注册: 2016-07-04 23:43
帖子: 16
系统: win2003 ubuntu16服务器
送出感谢: 0 次
接收感谢: 0 次
sudo mkdir -p /opt/cross
sudo wget https://downloads.openwrt.org/barrier_b ... .2.tar.bz2

sudo wget http://www.openssl.org/source/openssl-1.0.1g.tar.gz


sudo wget http://downloads.sourceforge.net/projec ... .9.tar.bz2

sudo wget https://alioth.debian.org/frs/download. ... 17.tar.bz2

sudo tar -xf OpenWrt-SDK-ramips-for-linux-x86_64-gcc-4.8-linaro_uClibc-0.9.33.2.tar.bz2 -C /opt/cross

sudo tar -xf libusb-1.0.9.tar.bz2 -C /opt/cross

sudo tar -xf openssl-1.0.1g.tar.gz -C /opt/cross


sudo tar -xf pcsc-lite-1.8.17.tar.bz2 -C /opt/cross

安装 How to install openssl/libcrypto

export TOOLCHAIN=/opt/cross/OpenWrt-SDK-ramips-for-linux-x86_64-gcc-4.8-linaro_uClibc-0.9.33.2/staging_dir/toolchain-mipsel_24kec+dsp_gcc-4.8-linaro_uClibc-0.9.33.2
export CC= /opt/cross/OpenWrt-SDK-ramips-for-linux-x86_64-gcc-4.8-linaro_uClibc-0.9.33.2/staging_dir/toolchain-mipsel_24kec+dsp_gcc-4.8-linaro_uClibc-0.9.33.2/bin/ mipsel-openwrt-linux-gcc
export RANLIB= /opt/cross/OpenWrt-SDK-ramips-for-linux-x86_64-gcc-4.8-linaro_uClibc-0.9.33.2/staging_dir/toolchain-mipsel_24kec+dsp_gcc-4.8-linaro_uClibc-0.9.33.2/bin/ mipsel-openwrt-linux-gcc-ranlib
sudo ./Configure --prefix=$TOOLCHAIN/usr/ linux-generic32 shared
sudo make
sudo make install
cd /opt
cd cross
cd libusb-1.0.9
export TOOLCHAIN=/opt/cross/OpenWrt-SDK-ramips-for-linux-x86_64-gcc-4.8-linaro_uClibc-0.9.33.2/staging_dir/toolchain-mipsel_24kec+dsp_gcc-4.8-linaro_uClibc-0.9.33.2
export PATH="$TOOLCHAIN/bin:$PATH"
sudo ./configure --prefix=$TOOLCHAIN/usr --host=mipsel-openwrt-linux-uclibc
sudo make
sudo make install
cd /opt
cd cross
cd pcsc-lite-1.8.17
export TOOLCHAIN=/opt/cross/OpenWrt-SDK-ramips-for-linux-x86_64-gcc-4.8-linaro_uClibc-0.9.33.2/staging_dir/toolchain-mipsel_24kec+dsp_gcc-4.8-linaro_uClibc-0.9.33.2
export PATH="$TOOLCHAIN/bin:$PATH"
export STAGING_DIR=/opt/cross/OpenWrt-SDK-ramips-for-linux-x86_64-gcc-4.8-linaro_uClibc-0.9.33.2/staging_dir
export CC=$TOOLCHAIN/bin/mipsel-openwrt-linux-gcc
sudo ./configure CC=$TOOLCHAIN/bin/mipsel-openwrt-linux-gcc-4.8.3 --disable-libudev --host=mipsel-openwrt-linux-uclibc --prefix=$TOOLCHAIN/usr --exec-prefix=$TOOLCHAIN/usr --disable-shared LIBUSB_LIBS="-L$TOOLCHAIN/usr/lib -lusb-1.0" LIBUSB_CFLAGS="-I$TOOLCHAIN/usr/include/libusb-1.0"
sudo ./configure CC=$TOOLCHAIN/bin/mipsel-unknown-linux-gnu-gcc-4.3.8 --disable-libudev --host= mipsel-openwrt-linux-uclibc --prefix=$TOOLCHAIN/usr --exec-prefix=$TOOLCHAIN/usr --disable-shared LIBUSB_LIBS="-L$TOOLCHAIN/usr/lib -lusb-1.0" LIBUSB_CFLAGS="-I$TOOLCHAIN/usr/include/libusb-1.0"

在编译安装 How to install openssl/libcrypto ibusb-1.0.9都没有问题,在编译PCSC 过程中sudo ./configure CC=$TOOLCHAIN/bin/mipsel-openwrt-linux-gcc-4.8.3 --disable-libudev --host=mipsel-openwrt-linux-uclibc --prefix=$TOOLCHAIN/usr --exec-prefix=$TOOLCHAIN/usr --disable-shared LIBUSB_LIBS="-L$TOOLCHAIN/usr/lib -lusb-1.0" LIBUSB_CFLAGS="-I$TOOLCHAIN/usr/include/libusb-1.0"
sudo ./configure CC=$TOOLCHAIN/bin/mipsel-unknown-linux-gnu-gcc-4.3.8 --disable-libudev --host= mipsel-openwrt-linux-uclibc --prefix=$TOOLCHAIN/usr --exec-prefix=$TOOLCHAIN/usr --disable-shared LIBUSB_LIBS="-L$TOOLCHAIN/usr/lib -lusb-1.0" LIBUSB_CFLAGS="-I$TOOLCHAIN/usr/include/libusb-1.0"运行时候出现C complier not work ,


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译