当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 无法安装g++
帖子发表于 : 2007-07-28 22:48 

注册: 2007-07-28 22:39
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
环境是ubuntu 6。06

想要安装basic-essential,但是返回的信息是:

The following packages have unmet dependencies:
build-essential: Depends: libc6-dev but it is not going to be installed or
libc-dev
Depends: g++ (>= 4:4.0) but it is not going to be installed
E: Broken packages

于是先 sudo apt-get install libc6-dev
返回结果是:
The following packages have unmet dependencies:
libc6-dev: Depends: libc6 (= 2.3.6-0ubuntu20.5) but 2.5-0ubuntu14 is to be installed
E: Broken packages
估计是libc6的现有版本不支持libc6-dev的安装,所有又打算删除现在机器里的libc6,从新立德里搜索到libc6,标记删除,
又提示“Could not apply changes!
Fix broken packages first”
然后在“编辑”菜单选择“fix broken packages“
返回
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
实在是不知道下一步该干什么了

请教高手该如何解决


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-09-12 21:34 
头像

注册: 2007-02-14 13:54
帖子: 308
送出感谢: 0 次
接收感谢: 0 次
为什么不先试试
sudo apt-get install g++


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-08 17:13 

注册: 2007-03-17 1:15
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
我也遇到类似的问题
安装g++的结果是

weicz@weicz-laptop:~/testc$ sudo apt-get install g++
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
g++: 依赖: g++-4.0 (>= 4.0.3) 但是它将不会被安装
E: 无法安装的软件包


这可怎么办阿


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-08 18:00 
头像

注册: 2007-03-13 17:26
帖子: 2254
送出感谢: 0 次
接收感谢: 1
禁用非官方源安装


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-17 19:23 

注册: 2007-09-18 18:46
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
我的系统是7.04
安装G++返回以下结果
错误 http://security.ubuntu.com feisty-security/main linux-libc-dev 2.6.20-16.31
404 Not Found
无法下载 http://security.ubuntu.com/ubuntu/pool/ ... 1_i386.deb 404 Not Found
E: 有几个软件包无法下载,您可以运行 apt-get update 或者加上 --fix-missing 的选项再试试?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-17 19:27 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
sudo aptitude install build-essential


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-01-29 13:33 

注册: 2008-01-24 1:39
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
这个命令很牛


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译