7.10下编译Reciteword一直也不成功

编译安装或者制作Deb包
回复
ooJerry
帖子: 49
注册时间: 2007-10-26 16:00
送出感谢: 0
接收感谢: 0

7.10下编译Reciteword一直也不成功

#1

帖子 ooJerry » 2007-11-10 12:54

checking for ngettext in libc... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for RECITEWORD... configure: error: Package requirements (gtk+-2.0 >= 2.2.0 gthread-2.0 >= 2.2.0 esound) were not met:

No package 'esound' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables RECITEWORD_CFLAGS
and RECITEWORD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

已经执行过sudo apt-get install esound可是还是说找不到
ooJerry
帖子: 49
注册时间: 2007-10-26 16:00
送出感谢: 0
接收感谢: 0

#2

帖子 ooJerry » 2007-11-10 14:32

who can help me
头像
daf3707
论坛版主
帖子: 12667
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

#3

帖子 daf3707 » 2007-11-10 14:47

我安装成功了,你干嘛不转成DEB包装,我转了之后安装成功,esound是安装了之后才又装了。就是有一个声音包100多M,其他的都30M左右,还好啦。
头像
daf3707
论坛版主
帖子: 12667
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

#4

帖子 daf3707 » 2007-11-10 14:52

我是看这里安装的,你可以试试http://www.linuxgem.org/tip/recite-words-in-linux-.html
ooJerry
帖子: 49
注册时间: 2007-10-26 16:00
送出感谢: 0
接收感谢: 0

#5

帖子 ooJerry » 2007-11-10 15:10

转换那个是可以成功,我是新新人,所以就想学习一下编译
头像
oneleaf
论坛管理员
帖子: 10219
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#6

帖子 oneleaf » 2007-11-10 15:15

No package 'esound' found
安装一个esound试试?
ooJerry
帖子: 49
注册时间: 2007-10-26 16:00
送出感谢: 0
接收感谢: 0

#7

帖子 ooJerry » 2007-11-10 15:28

已经执行过sudo apt-get install esound

并提示成功安装了

$ sudo apt-get install esound
Reading package lists... Done
Building dependency tree
Reading state information... Done
esound is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
头像
daf3707
论坛版主
帖子: 12667
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

#8

帖子 daf3707 » 2007-11-12 17:38

那你就要看文件里,搜索esound,注意看看他后面的版本号,改成与你安装版本相同的,再编译
vangie
帖子: 26
注册时间: 2008-04-29 23:11
送出感谢: 0
接收感谢: 0

#9

帖子 vangie » 2008-05-03 2:18

sudo apt-get install libesd0-dev
回复

回到 “编译或打包”