当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]编译fvwm-2.5.16时的问题
帖子发表于 : 2007-12-09 19:19 

注册: 2007-06-04 21:08
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
在CU下了个fvwm2.5.16和fvwm-2.5.16-translucent-menus.diff.gz,补丁打上了,可是在运行 ./configure 时发生这样的情况


leung@leungfax:~/fvwm$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable command logging... no
checking whether to enable debugging messages... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for X... no

X11 libraries or header files could not be found. Please make
sure the X11 development package is installed on your system.
If it is definitely installed, try setting the include and library
paths with the --x-include and --x-libraries options of configure.
Fvwm can not be compiled without the X11 development environment.

Aborting.

然后我在网上搜索,有人说是要装上libx11-dev,于是我就sudo apt-get install libx11-dev,系统提示我的xlib11-dev是最新的了。 哪位高人指点一下啊,谢谢!~~


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-09 19:22 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
源里面有
代码:
$ aptitude show fvwm
软件包: fvwm
新: 是
状态: 未安装
版本号: 1:2.5.21-1
优先级: 可选
部分: universe/x11
维护者: Ubuntu MOTU Developers <ubuntu-motu@lists.ubuntu.com>
未压缩尺寸: 6824k
依赖于: gdk-imlib11, libc6 (>= 2.5-0ubuntu1), libfontconfig1 (>= 2.4.0),
           libfreetype6 (>= 2.2), libfribidi0 (>= 0.10.7), libglib1.2 (>=
           1.2.0), libgtk1.2 (>= 1.2.10-4), libice6 (>= 1:1.0.0), libncurses5
           (>= 5.4-5), libpng12-0 (>= 1.2.13-4), libreadline5 (>= 5.2),
           librplay3 (>= 3.3.2-2), libsm6, libstroke0 (>= 0.5.1), libx11-6,
           libxext6, libxft2 (> 2.1.1), libxi6, libxinerama1, libxpm4,
           libxrender1, zlib1g (>= 1:1.2.1)
预依赖于: debconf (>= 1.2.0) | debconf-2.0
推荐: fvwm-icons
建议: m4, cpp, menu (>= 1.5), wm-icons, perl-tk, libx11-protocol-perl
冲突: fvwm-beta, fvwm-common, fvwm-gnome, fvwmtabs
代替: fvwm-beta, fvwm-common, fvwmtabs
提供: x-window-manager
描述: F(?) Virtual Window Manager, version 2.5
 FVWM is a powerful ICCCM2 compliant multiple virtual desktop window manager for
 the X Window System. FVWM requires relatively little memory.
 
 This 2.5 version includes new features like full support of the EWMH (Extended
 Window Manager Hints) specification, internationalization, improved window
 decoration code (no flickering anymore), bi-directional asian text support,
 FreeType font support (antialiasing), image rendering, Perl based module
 library, support for PNG images, side titles and much more.



_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-09 19:54 

注册: 2007-06-04 21:08
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
这个我知道,源里面那个可以用translucent么?
另外那些依赖的包我的系统都已经有最新版,那
X11 libraries or header files could not be found. Please make
sure the X11 development package is installed on your system.
If it is definitely installed, try setting the include and library
paths with the --x-include and --x-libraries options of configure.
Fvwm can not be compiled without the X11 development environment.

这一段怎解?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-09 20:48 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
build-dep
build-dep causes apt-get to install/remove packages in an attempt to satisfy the
build dependencies for a source package.
先下了需要的依赖源码。

不知道你为什么要编译。一个wm是需要全部X11支持库的。编译以后,也不一定具有你需要的特性。
上gentoo去编译吧。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-27 1:40 
头像

注册: 2006-11-29 12:13
帖子: 129
地址: china beijing
送出感谢: 0 次
接收感谢: 0 次
安装相应的依赖包和libx11-dev之后就可以安装了 :D


_________________
I.A.J.M - linux is so attractive!

blog:http://hi.baidu.com/leepeng


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译