./configure时出现这样的错误,请指教!(问题还未解决,请继续关注!)

编译安装或者制作Deb包
回复
coldphn
帖子: 6
注册时间: 2006-01-02 9:17
送出感谢: 0
接收感谢: 0

./configure时出现这样的错误,请指教!(问题还未解决,请继续关注!)

#1

帖子 coldphn » 2006-02-15 13:58

在安装一软件时出现如下错误:
$ sudo ./configure
loading cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... (cached) yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... missing
checking for gcc... (cached) gcc
checking whether the C compiler (gcc ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.


用apt找不到makeinfo软件。gcc已经安装了,为什么他没正常工作?还要怎么配置?
谢谢! :D
上次由 coldphn 在 2006-02-15 17:01,总共编辑 1 次。
wesley
帖子: 2
注册时间: 2006-02-13 17:21
送出感谢: 0
接收感谢: 0

#2

帖子 wesley » 2006-02-15 15:07

install gcc will solve this problem~
游客
送出感谢: 0
接收感谢: 0

#3

帖子 游客 » 2006-02-15 15:09

谢谢,不过在新立得已经安装了gcc,还应改做什么?
头像
roylez
论坛版主
帖子: 1928
注册时间: 2005-10-04 10:59
来自: 上海
送出感谢: 0
接收感谢: 1 次

#4

帖子 roylez » 2006-02-15 19:16

也许需要其他版本的gcc,比如gcc 3.4。你可以试试将几个不同版本的gcc都装上。
弄个dropbox空间来备份文件或者做私人代码服务器
配置:[url]git://github.com/roylez/dotfiles.git[/url]
主页:http://roylez.heroku.com
各种稀奇玩意儿:http://dooloo.info
jameschen
帖子: 1
注册时间: 2006-02-15 20:01
送出感谢: 0
接收感谢: 0

#5

帖子 jameschen » 2006-02-15 20:07

sudo apt-get install gcc
mcwin
帖子: 5
注册时间: 2005-12-05 12:27
送出感谢: 0
接收感谢: 0

装个库吧

#6

帖子 mcwin » 2006-03-03 10:48

apt-get install glibc6-dev
头像
freeflying
论坛版主
帖子: 521
注册时间: 2005-03-26 9:38
送出感谢: 0
接收感谢: 0

#7

帖子 freeflying » 2006-03-03 11:08

sudo apt-get install build-essenstial
图片
aubrey
帖子: 33
注册时间: 2006-04-27 11:21
送出感谢: 0
接收感谢: 0

#8

帖子 aubrey » 2006-06-17 2:57

7楼正解
star_s
帖子: 24
注册时间: 2006-10-11 19:09
送出感谢: 0
接收感谢: 0

#9

帖子 star_s » 2006-11-01 19:06

freeflying 写了:sudo apt-get install build-essenstial

命令打错了,应该是

代码: 全选

sudo apt-get install build-essential
热爱开源……
jpu
帖子: 2
注册时间: 2007-11-22 3:08
送出感谢: 0
接收感谢: 0

#10

帖子 jpu » 2007-11-22 3:10

ME TOO。
先用apt-get install build-essential 解决不了问题。
用 apt-get install texinfo 搞定
jpu
帖子: 2
注册时间: 2007-11-22 3:08
送出感谢: 0
接收感谢: 0

#11

帖子 jpu » 2007-11-22 3:43

如果configure: error: installation or configuration problem: C compiler cannot create executables. 用apt-get install build-essential 解决。
如果后面有 makeinfo 的错误,再用 apt-get install texinfo 搞定
palxex
帖子: 136
注册时间: 2006-10-30 11:23
送出感谢: 0
接收感谢: 0

#12

帖子 palxex » 2007-11-22 15:17

这个情况最好是把config.log发上来好分析。makeinfo找不到一般也能过,不过安装阶段可能会出点儿麻烦。
回复

回到 “编译或打包”