当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]小企鹅输入法源代码编译出错
帖子发表于 : 2008-01-07 17:22 

注册: 2008-01-07 17:00
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
以下是出错信息:
ddo:~/桌面/fcitx-3.5> make
make all-recursive
make[1]: Entering directory `/home/ddo/桌面/fcitx-3.5'
Making all in doc
make[2]: Entering directory `/home/ddo/桌面/fcitx-3.5/doc'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/ddo/桌面/fcitx-3.5/doc'
Making all in xpm
make[2]: Entering directory `/home/ddo/桌面/fcitx-3.5/xpm'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/ddo/桌面/fcitx-3.5/xpm'
Making all in lib
make[2]: Entering directory `/home/ddo/桌面/fcitx-3.5/lib'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/ddo/桌面/fcitx-3.5/lib'
Making all in src
make[2]: Entering directory `/home/ddo/桌面/fcitx-3.5/src'
if gcc -DPKGDATADIR=\"/usr/local/share/fcitx\" -I. -I. -I.. -I. -I../lib -I../xpm -O2 -fno-strength-reduce -g -O2 -I/usr/include/freetype2 -D_USE_XFT -Wall -MT InputWindow.o -MD -MP -MF ".deps/InputWindow.Tpo" -c -o InputWindow.o InputWindow.c; \
then mv -f ".deps/InputWindow.Tpo" ".deps/InputWindow.Po"; else rm -f ".deps/InputWindow.Tpo"; exit 1; fi
InputWindow.c:30:21: 错误: X11/xpm.h:No such file or directory
InputWindow.c: 在函数 ‘DrawInputWindow’ 中:
InputWindow.c:236: 错误: ‘XpmAttributes’ 未声明 (在此函数内第一次使用)
InputWindow.c:236: 错误: (即使在一个函数内多次出现,每个未声明的标识符在其
InputWindow.c:236: 错误: 所在的函数内只报告一次。)
InputWindow.c:236: 错误: expected ‘;’ before ‘attrib’
InputWindow.c:307: 警告: 隐式声明函数 ‘isprint’
InputWindow.c:414: 错误: ‘attrib’ 未声明 (在此函数内第一次使用)
InputWindow.c:435: 警告: 隐式声明函数 ‘XpmCreateImageFromData’
InputWindow.c:436: 错误: ‘XpmSuccess’ 未声明 (在此函数内第一次使用)
make[2]: *** [InputWindow.o] 错误 1
make[2]: Leaving directory `/home/ddo/桌面/fcitx-3.5/src'
make[1]: *** [all-recursive] 错误 1
make[1]: Leaving directory `/home/ddo/桌面/fcitx-3.5'
make: *** [all] 错误 2
各位猛将兄帮忙看看,谢谢了。这个代码在fc6下运行很好的。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-07 18:01 
头像

注册: 2007-01-15 17:15
帖子: 3766
送出感谢: 0 次
接收感谢: 0 次
我帮你顶, 我这里 apt 不来 fcitx source , 帮不上忙了

另外: Fc6 就是比 ubuntu 强,别客气,想说就说 :)


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-08 19:47 

注册: 2008-01-07 17:00
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
还有没有人关注这个帖子啊?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-14 17:09 
头像

注册: 2007-09-23 17:06
帖子: 1051
送出感谢: 1
接收感谢: 8
wo ye shi zhe ge wen ti !
bu zhi dao zhen mo hui shi ?
bu xiang yong yuan li de !ban ben tai di !


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-14 17:54 
头像

注册: 2007-09-23 17:06
帖子: 1051
送出感谢: 1
接收感谢: 8
呵呵!我成功了!
我也遇到 了 这个问题了!然后上网查找,终于解决了,其实就是少装了一个Fcitx(并且成X11有关)所依赖的库文件!
对了,先篇章的介绍几个命令:
apt-cache search # ------(package 搜索包)
apt-cache show #------(package 获取包的相关信息,如说明、大小、版本等)
sudo apt-get install # ------(package 安装包)
sudo apt-get install # -----(package - - reinstall 重新安装包)
sudo apt-get -f install # -----(强制安装?#"-f = --fix-missing"当是修复安装吧...)
sudo apt-get remove #-----(package 删除包)
sudo apt-get remove - - purge # ------(package 删除包,包括删除配置文件等)
sudo apt-get autoremove --purge # ----(package 删除包及其依赖的软件包+配置文件等(只对6.10有效,强烈推荐))
sudo apt-get update #------更新源
sudo apt-get upgrade #------更新已安装的包
sudo apt-get dist-upgrade # ---------升级系统
sudo apt-get dselect-upgrade #------使用 dselect 升级
apt-cache depends #-------(package 了解使用依赖)
apt-cache rdepends # ------(package 了解某个具体的依赖?#当是查看该包被哪些包依赖吧...)
sudo apt-get build-dep # ------(package 安装相关的编译环境)
apt-get source #------(package 下载该包的源代码)
sudo apt-get clean && sudo apt-get autoclean # --------清理下载文件的存档 && 只清理过时的包
sudo apt-get check #-------检查是否有损坏的依赖


最重要 的就是依据这个提示:InputWindow.c:30:21: 错误: X11/xpm.h:No such file or directory 我猜想是少了与xpm有关的程序,于是就用上面的

sudo apt-get cache search xpm

进行查找,果然找到了一些,
。。。
libsdl-image1.2-dev - development files for SDL 1.2 image loading libray
libxpm-dev - X11 pixmap library (development headers)
libxpm4 - X11 pixmap library
。。。

于是就安装了
sudo apt-get install libxpm-dev
然后安装成功,就可以再次编译,成功!
呵呵,试试吧!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-14 23:40 
头像

注册: 2007-05-05 23:30
帖子: 562
送出感谢: 0 次
接收感谢: 0 次
楼主在哪儿弄的源码包?我的fcitx版本太低了(源里直接装的)。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-01-15 12:03 
头像

注册: 2007-09-23 17:06
帖子: 1051
送出感谢: 1
接收感谢: 8
kwindva 写道:
楼主在哪儿弄的源码包?我的fcitx版本太低了(源里直接装的)。

fcitx的官方站点:
http://www.fcitx.org/main/?q=node/9




页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译