[问题]怎么ubuntu下rubygems 不能升级?

Python/PHP/Perl 开发与设计
回复
isaiah
帖子: 7
注册时间: 2008-01-02 12:57
送出感谢: 0
接收感谢: 0

[问题]怎么ubuntu下rubygems 不能升级?

#1

帖子 isaiah » 2008-01-15 19:38

我的ubuntu是7.10,装了rubygems是0.9.4版,升级rubygems的时候报错Access Denied。因为rubygems不能升级,导致rails也不能升级到最新版本,不知道是ubuntu系统本身的限制还是其他原因?也找过很多源,但都是这个现象。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2008-01-15 19:40

不要安装源里面的gem, 请手工下载gem的rb包安装. 另外呢. gem运行的时候前面要加上sudo
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
isaiah
帖子: 7
注册时间: 2008-01-02 12:57
送出感谢: 0
接收感谢: 0

#3

帖子 isaiah » 2008-01-15 19:48

我手工把1.0.1版的gem 和.tgz都下载下来了,gem包不知道怎么安装,.tgz解压后,用sudo ruby setup.rb安装,没有错误,但使用 gem -v 的时候报错 undefined constant Gem:
回复

回到 “Python/Php/Perl”