当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]ubuntu7.10安装RMagick出错
帖子发表于 : 2008-01-21 15:17 

注册: 2008-01-02 12:57
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
在终端输入$ irb -rubygems -r RMagick出现以下错误:
/usr/lib/ruby/gems/1.8/gems/rmagick-2.1.0/lib/RMagick2.so: /usr/lib/ruby/gems/1.8/gems/rmagick-2.1.0/lib/RMagick2.so: undefined symbol: SketchImage - /usr/lib/ruby/gems/1.8/gems/rmagick-2.1.0/lib/RMagick2.so (LoadError)
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
from /usr/lib/ruby/gems/1.8/gems/rmagick-2.1.0/lib/RMagick.rb:11
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:32:in `gem_original_require'
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:32:in `require'
from /usr/lib/ruby/1.8/irb/init.rb:252:in `load_modules'
from /usr/lib/ruby/1.8/irb/init.rb:250:in `each'
from /usr/lib/ruby/1.8/irb/init.rb:250:in `load_modules'
from /usr/lib/ruby/1.8/irb/init.rb:21:in `setup'
from /usr/lib/ruby/1.8/irb.rb:54:in `start'
from /usr/bin/irb:13
已装好ImageMagick6.3.7,通过$convert -version:
Version: ImageMagick 6.3.7 01/20/08 Q8 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2008 ImageMagick Studio LLC
RMagick本地安装和通过rubygems安装都出现同样的问题。
rails和rubygems 都为最新版。
在网上找过很多方法都不行:如在环境变量设置export LD_LIBRARY_PATH=/usr/local/lib等


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译