求助python IDE环境

Python/PHP/Perl 开发与设计
hsl4125
帖子: 33
注册时间: 2008-01-18 13:22
送出感谢: 0
接收感谢: 0
联系:

求助python IDE环境

#1

帖子 hsl4125 » 2008-01-31 15:17

本人是一菜鸟,刚刚开始学习编程。不知python有什么比较好用的IDE环境没有?系统自带的IDLE太老了,想换个更好用的。求大虾帮忙!能否帮忙打个包,帮小弟解决这个问题!
头像
shellex
帖子: 2180
注册时间: 2007-02-18 19:33
系统: OSX
来自: lyric.im
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 shellex » 2008-01-31 15:31

python的IDE啊...
去python.org看呗。
http://wiki.python.org/moin/PythonEditors

推荐Eclipse吧。
不过我不用。
hsl4125
帖子: 33
注册时间: 2008-01-18 13:22
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 hsl4125 » 2008-01-31 15:43

我英文不好,基本上不知所云!请问二楼一下,你用什么写python?
xep007
帖子: 870
注册时间: 2006-01-03 20:44
送出感谢: 0
接收感谢: 6 次

#4

帖子 xep007 » 2008-01-31 17:05

hsl4125 写了:我英文不好,基本上不知所云!请问二楼一下,你用什么写python?
我也不懂PYTHON,不过用vim或emacs都很好用的。只要配置一下即可。
头像
roylez
论坛版主
帖子: 1928
注册时间: 2005-10-04 10:59
来自: 上海
送出感谢: 0
接收感谢: 1 次

#5

帖子 roylez » 2008-02-01 16:30

我用没有专门针对python配置的vim有好一阵子了。
hsl4125
帖子: 33
注册时间: 2008-01-18 13:22
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 hsl4125 » 2008-02-01 22:31

呵呵,我菜鸟一个,什么VIM之类的我根本就用不好,真不知道该从何下手啊!
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 karron » 2008-02-01 22:42

eric
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
shellex
帖子: 2180
注册时间: 2007-02-18 19:33
系统: OSX
来自: lyric.im
送出感谢: 0
接收感谢: 1 次
联系:

#8

帖子 shellex » 2008-02-01 23:35

roylez 写了:我用没有专门针对python配置的vim有好一阵子了。
哦我也是。
wgn
帖子: 164
注册时间: 2006-04-29 15:54
来自: CUGB
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 wgn » 2008-02-03 11:44

最简单的gedit就可以
vim,emacs都可以胜任
eric,spe,eclipse+pydev
hsl4125
帖子: 33
注册时间: 2008-01-18 13:22
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 hsl4125 » 2008-02-05 16:34

谁有komodo ide 据说很好用,可惜不是免费的。那位老大有破解版的?发上来共享一下!
kevinzhang
帖子: 66
注册时间: 2007-12-05 20:20
送出感谢: 0
接收感谢: 0

#11

帖子 kevinzhang » 2008-02-11 21:52

那么多免费的,何必要用有版权限制的软件,呵呵
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 karron » 2008-02-11 22:05

komodo kde是要钱的, 可以用komodo edit, 免费的.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
百草谷居士
帖子: 2989
注册时间: 2006-02-10 16:36
系统: ubuntu18.04/Win10
送出感谢: 18 次
接收感谢: 32 次
联系:

#13

帖子 百草谷居士 » 2008-02-15 9:13

使用新立得安装vim-python包就可以使vim支持python了。
友帮拓,真难听。有没有接触官方的老大?给改了吧!
一直想找一个在linux下的Visual FoxPro/access桌面数据库。MUIBase还算是最相近的。
头像
seanone
帖子: 119
注册时间: 2007-03-13 15:49
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 seanone » 2008-02-25 4:22

呵呵,本来在win下Ulipad挺好用,代码提示与自动完成都很棒,但在这里代码自动完成这个功能很诡异,有兴趣的朋友可以试试。如果对,我推荐用源里的Geany,如果你些web,我觉得用这个也挺不错的。另外,如果些wx,用boa当然没错,如果要支持wxPython2.8,记得去官网下最新的0.6.1版。
hsl4125
帖子: 33
注册时间: 2008-01-18 13:22
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 hsl4125 » 2008-03-27 21:17

其实Eclipse最好用!
回复

回到 “Python/Php/Perl”