DJango不能在apache1.3里用么?

Python/PHP/Perl 开发与设计
回复
ynzheng
帖子: 74
注册时间: 2005-12-28 14:12
送出感谢: 0
接收感谢: 0
联系:

DJango不能在apache1.3里用么?

#1

帖子 ynzheng » 2006-05-16 14:27

DJango不能在apache1.3里用么?


在ubuntu 5.10里有
--------

代码: 全选

username@colinux:/etc/apache2$ apt-cache search mod-python
libapache2-mod-python - An Apache module that embeds Python within the server
libapache2-mod-python-doc - An Apache module that embeds Python within the server
libapache2-mod-python2.4 - An Apache 2 module that embeds Python 2.4 within the server
libapache-mod-python - An Apache module that embeds Python within the server
libapache-mod-python-doc - An Apache module that embeds Python within the server
libapache-mod-python2.3 - An Apache module that embeds Python 2.3 within the server
libapache-mod-python2.4 - An Apache module that embeds Python 2.4 within the server
libapache2-mod-python2.3 - An Apache 2 module that embeds Python 2.3 within the server
--------
我想用apache1.3+php4+mysql5+python+django...
可是安装了
libapache-mod-python
libapache-mod-python2.4
通过phpinfo没有任何python,找了半天没有任何apache python module,应该如何配置apache呢?

还需要安装mod-python么?

或者谁知道libapache-mod-python(或者libapache2-mod-python)
和mod-python有什么区别呢?
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2006-05-24 17:18

不能,只能在apache2上用的.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
ynzheng
帖子: 74
注册时间: 2005-12-28 14:12
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 ynzheng » 2006-05-24 17:28

可是mod-python不是有1。3版本么?
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 karron » 2006-05-24 19:31

mod-python不是只为django准备的……

django官方这么说的。

How to use Django with mod_python
This covers the Django development version, which is significantly different than previous versions. Old docs: 0.90, 0.91

Apache with mod_python currently is the preferred setup for using Django on a production server.

mod_python is similar to mod_perl : It embeds Python within Apache and loads Python code into memory when the server starts. Code stays in memory throughout the life of an Apache process, which leads to significant performance gains over other server arrangements.

Django requires Apache 2.x and mod_python 3.x.

We recommend you use Apache's prefork MPM, as opposed to the worker MPM.[/b]
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “Python/Php/Perl”