python2.5-dev装不上去,,,,大家帮忙看看

Python/PHP/Perl 开发与设计
回复
头像
hellojinjie
帖子: 1144
注册时间: 2007-09-14 21:03
来自: 浙江
送出感谢: 0
接收感谢: 0

python2.5-dev装不上去,,,,大家帮忙看看

#1

帖子 hellojinjie » 2008-10-03 21:36

代码: 全选

jj@hellojinjie:~$ sudo apt-get install python2.5-dev
[sudo] password for jj: 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
读取状态信息... 完成             
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  python2.5-dev: 依赖: python2.5 (= 2.5.2-2ubuntu4) 但是 2.5.2-2ubuntu4.1 正要被安装
E: 无法安装的软件包
这个错误说明有点让人摸不着脑袋,,,,,,,,,
Say hello to everyday!
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

Re: python2.5-dev装不上去,,,,大家帮忙看看

#2

帖子 BigSnake.NET » 2008-10-03 21:39

先做一次 apt-get update

再试试
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
hellojinjie
帖子: 1144
注册时间: 2007-09-14 21:03
来自: 浙江
送出感谢: 0
接收感谢: 0

Re: python2.5-dev装不上去,,,,大家帮忙看看

#3

帖子 hellojinjie » 2008-10-03 22:19

BigSnake.NET 写了:先做一次 apt-get update

再试试
直接更新没用
不过我换了源后再更新就解决了 :em11
Say hello to everyday!
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

Re: python2.5-dev装不上去,,,,大家帮忙看看

#4

帖子 karron » 2008-10-03 22:51

你自己用的源的版本不对吧, 也许804的系统, 却用的是710的源.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
hellojinjie
帖子: 1144
注册时间: 2007-09-14 21:03
来自: 浙江
送出感谢: 0
接收感谢: 0

Re: python2.5-dev装不上去,,,,大家帮忙看看

#5

帖子 hellojinjie » 2008-10-03 23:25

karron 写了:你自己用的源的版本不对吧, 也许804的系统, 却用的是710的源.
这个m诶注意到过啊,,,,,

我刚开始的时候用的默认的国际官方源,,,不是cn的
Say hello to everyday!
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

Re: python2.5-dev装不上去,,,,大家帮忙看看

#6

帖子 想入非非 » 2008-10-04 2:25

难道又是源的问题。。。 :em06
Ubuntu User
回复

回到 “Python/Php/Perl”