Ruby问题:gem安装rails没有加入系统命令怎么办?

Python/PHP/Perl 开发与设计
回复
头像
asuka08
帖子: 25
注册时间: 2009-01-05 22:26
送出感谢: 0
接收感谢: 0

Ruby问题:gem安装rails没有加入系统命令怎么办?

#1

帖子 asuka08 » 2009-01-18 20:58

Ubuntu 8.10
想安装RoR环境
ruby用apt-get安装的,版本1.8.7
然后用sudo gem install rails --include-dependencies
过了一会儿安装好了
但是这时用rails -v命令查看rails版本却提示没有该命令
用gem query --local显示已安装的gem显示有rails
怀疑是rails没有加入系统命令
请问如何解决?
头像
asuka08
帖子: 25
注册时间: 2009-01-05 22:26
送出感谢: 0
接收感谢: 0

Re: Ruby问题:gem安装rails没有加入系统命令怎么办?

#2

帖子 asuka08 » 2009-01-18 21:15

算了,直接建个链接得了

sudo ln -s /var/lib/gems/1.8/bin/rails /usr/bin/rails
头像
ChloeRei
帖子: 1021
注册时间: 2007-11-23 9:49
送出感谢: 0
接收感谢: 1 次

Re: Ruby问题:gem安装rails没有加入系统命令怎么办?

#3

帖子 ChloeRei » 2009-01-19 2:25

问一下,--include-dependencies是不是必须的?
见http://rubyonrails.org/download 这里没写就没加那句

我只用apt安装ruby和rdoc,gem和rails都手工装
头像
anticlockwise
帖子: 2393
注册时间: 2007-03-01 20:46
来自: 湖南长沙
送出感谢: 0
接收感谢: 0
联系:

Re: Ruby问题:gem安装rails没有加入系统命令怎么办?

#4

帖子 anticlockwise » 2009-01-19 3:25

ChloeRei 写了:问一下,--include-dependencies是不是必须的?
见http://rubyonrails.org/download 这里没写就没加那句

我只用apt安装ruby和rdoc,gem和rails都手工装


如果只是想要命令顺利运行,不用也可以,--include-dependencies只是将你要装的包的所有依赖都下载并且安装上~~
回复

回到 “Python/Php/Perl”