当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 如何安装numpy阿
帖子发表于 : 2009-07-05 17:58 

注册: 2008-09-19 3:26
帖子: 103
送出感谢: 0 次
接收感谢: 0 次
要求是,
To build with g77:

python setup.py build --fcompiler=gnu

To build with gfortran:

python setup.py build --fcompiler=gnu95

还说要检查 the ABI of blas/lapack/atlas
什么事blas/lapack/atlas阿?

下面是 用上面两个命令行执行中的错误信息
numpy.distutils.fcompiler.CompilerNotFound: gnu95: f90 nor f77


Could not locate executable g77
Could not locate executable f77
customize IntelFCompiler
Could not locate executable ifort
Could not locate executable ifc
customize LaheyFCompiler
Could not locate executable lf95
customize PGroupFCompiler
Could not locate executable pgf90
Could not locate executable pgf77
customize AbsoftFCompiler
Could not locate executable f90
customize NAGFCompiler
Could not locate executable f95
customize VastFCompiler
customize GnuFCompiler
customize CompaqFCompiler
Could not locate executable fort
customize IntelItaniumFCompiler
Could not locate executable efort
Could not locate executable efc
customize IntelEM64TFCompiler
customize Gnu95FCompiler
Could not locate executable gfortran
customize G95FCompiler
Could not locate executable g95
don't know how to compile Fortran code on platform 'posix'


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 如何安装numpy阿
帖子发表于 : 2009-07-05 19:53 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
源中没有么? 为什么要自己编译呢?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 如何安装numpy阿
帖子发表于 : 2009-07-06 19:31 
头像

注册: 2007-03-01 20:46
帖子: 2393
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
想要自己编译的话:

sudo apt-get build-dep python-numpy

就会安装好依赖包,然后再编译

其实源中的已经够新了:sudo apt-get install python-numpy


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译