关于ubuntu10.10安装python2.5的问题,sqlite3找不到...

Python/PHP/Perl 开发与设计
回复
MC_Vector
帖子: 14
注册时间: 2010-01-09 0:03
送出感谢: 0
接收感谢: 0

关于ubuntu10.10安装python2.5的问题,sqlite3找不到...

#1

帖子 MC_Vector » 2010-12-29 3:08

由于要想在google app engine上开发web,所以要安装python2.5,但是ubuntu10.10 自带的是 python2.6的版本
问题出现了,原来我安装了sqlite3的,然后在2.6一切正常
1.于是我下载了一个python2.5,编译安装,python shell版本也成2.5.5了,一切正常,但是import sqlite3的时候就找不到sqlite3模块了,崩溃啊。
2.更悲剧的是,我试着用sudo apt-get install --reinstall python-pysqlite2妄图重新安装一下接口的时候,出现了:

代码: 全选

Preparing to replace python-pysqlite2 2.6.0-1 (using .../python-pysqlite2_2.6.0-1_i386.deb) ...
/var/lib/dpkg/info/python-pysqlite2.prerm: 46: pycentral: Permission denied
dpkg: warning: subprocess old pre-removal script returned error exit status 126
dpkg - trying script from the new package instead ...
/var/lib/dpkg/tmp.ci/prerm: 46: pycentral: Permission denied
dpkg: error processing /var/cache/apt/archives/python-pysqlite2_2.6.0-1_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 126
/var/lib/dpkg/info/python-pysqlite2.postinst: 10: pycentral: Permission denied
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 126
Errors were encountered while processing:
 /var/cache/apt/archives/python-pysqlite2_2.6.0-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
现在悲剧的apt-get神马都是那个问题了。

Finally: 现在是想删掉原来的2.5也没办法,想用2.5也没有现在想用的sqlite3,而且apt-get也悲剧了 :em20
。。。求解决啊~~~~
头像
icyomik
帖子: 76
注册时间: 2010-10-30 17:52
送出感谢: 0
接收感谢: 0

Re: 关于ubuntu10.10安装python2.5的问题,sqlite3找不到...

#2

帖子 icyomik » 2010-12-31 22:50

Permission denied ?
个人博客:http://blog.jtwo.me/
女友淘宝:http://icykiss.taobao.com/
你有什么不开心的事情,说出来让大家开心一下。
回复

回到 “Python/Php/Perl”