edgy 无法安装ruby

Python/PHP/Perl 开发与设计
回复
killercat
帖子: 68
注册时间: 2006-10-16 15:22
送出感谢: 0
接收感谢: 0

edgy 无法安装ruby

#1

帖子 killercat » 2006-11-18 22:22

使用源码无法在edgy下安装ruby...

checking build system type... i686-pc-linux-gnulibc1
checking host system type... i686-pc-linux-gnulibc1
checking target system type... i686-pc-linux-gnulibc1
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.

系统默认装了gcc的:

gcc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --enable-checking=release i486-linux-gnu
Thread model: posix
gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)

有人知道这是为什么吗?
killercat
帖子: 68
注册时间: 2006-10-16 15:22
送出感谢: 0
接收感谢: 0

#2

帖子 killercat » 2006-11-18 23:02

知道原因了,edgy默认装上gcc,但是不带库已经有关文件,假如需要源码安装则出现问题,gcc无法使用,解决版本:

sudo apt-get install build-essential

安装开发环境即可
oldbeggar
帖子: 102
注册时间: 2006-01-19 13:14
送出感谢: 0
接收感谢: 0

#3

帖子 oldbeggar » 2007-02-16 9:53

正解
几乎所有的 软件,从源码安装都需要安装这个包
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 karron » 2007-02-16 9:56

ruby源里面就有啊,rails也有.不需要自己编译.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “Python/Php/Perl”