当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教tar: 您不能指定超过一个“-Acdtrux”或是“--test-label”外的选项
帖子发表于 : 2011-05-04 10:03 

注册: 2011-05-03 18:00
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
在安装xampp时,输入如下命令:tar xvfz xampp-linux-1.5.3a.tar.gz -c /opt
之后提示tar: 您不能指定超过一个“-Acdtrux”或是“--test-label”外的选项
刚刚接触ubuntu,还请各位高手帮解答一下,在线等。。。。谢谢了


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请教tar: 您不能指定超过一个“-Acdtrux”或是“--test-label”外的选项
帖子发表于 : 2011-05-04 10:56 
头像

注册: 2009-04-11 23:46
帖子: 4130
系统: Arch Linux
送出感谢: 11
接收感谢: 124
f 选项要放在文件名前,也就是那群选项的最后一个。


_________________
我的博客 https://blog.lilydjwg.me/
提问的智慧
Arch Linux 中文论坛

我的vimrc: https://git.io/vimrc


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 请教tar: 您不能指定超过一个“-Acdtrux”或是“--test-label”外的选项
帖子发表于 : 2011-05-04 11:47 

注册: 2011-05-03 18:00
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
lilydjwg 写道:
f 选项要放在文件名前,也就是那群选项的最后一个。

我把f放在了选项的最后一个 还是按照原来的提示啊,没有变化啊


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 请教tar: 您不能指定超过一个“-Acdtrux”或是“--test-label”外的选项
帖子发表于 : 2011-05-04 13:30 
头像

注册: 2009-04-11 23:46
帖子: 4130
系统: Arch Linux
送出感谢: 11
接收感谢: 124
终于看出来了——那个 -c 应该是大写的 -C


_________________
我的博客 https://blog.lilydjwg.me/
提问的智慧
Arch Linux 中文论坛

我的vimrc: https://git.io/vimrc


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 请教tar: 您不能指定超过一个“-Acdtrux”或是“--test-label”外的选项
帖子发表于 : 2011-05-04 15:14 

注册: 2011-05-03 18:00
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
lilydjwg 写道:
终于看出来了——那个 -c 应该是大写的 -C

改成大写的确实没有那个提示了 但是提示好多文件找不到
lampp/lib/perl5/site_perl/5.8.7/i686-linux/auto/APR/Request/CGI/CGI.so
tar:lampp/lib/perl5/site_perl/5.8.7/i686-linux/auto/APR/Request/CGI/CGI.so:无法 open:没有那个文件和目录
都是向上边那样的提示,开始以为是权限的问题,查了一下不是权限啊。
我就直接把xampp-linux-1.5.3a.tar.gz下载到自己的文件夹里了,直接输入tar xvzf xampp-linux-1.5.3a.tar.gz -C /opt 就提示上边那些了,请问能能看出什么问题吗


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 请教tar: 您不能指定超过一个“-Acdtrux”或是“--test-label”外的选项
帖子发表于 : 2011-05-04 17:47 
头像

注册: 2009-04-11 23:46
帖子: 4130
系统: Arch Linux
送出感谢: 11
接收感谢: 124
buptzhou 写道:
lilydjwg 写道:
终于看出来了——那个 -c 应该是大写的 -C

改成大写的确实没有那个提示了 但是提示好多文件找不到
lampp/lib/perl5/site_perl/5.8.7/i686-linux/auto/APR/Request/CGI/CGI.so
tar:lampp/lib/perl5/site_perl/5.8.7/i686-linux/auto/APR/Request/CGI/CGI.so:无法 open:没有那个文件和目录
都是向上边那样的提示,开始以为是权限的问题,查了一下不是权限啊
我就直接把xampp-linux-1.5.3a.tar.gz下载到自己的文件夹里了,直接输入tar xvzf xampp-linux-1.5.3a.tar.gz -C /opt 就提示上边那些了,请问能能看出什么问题吗


你确定你的权限没问题?


_________________
我的博客 https://blog.lilydjwg.me/
提问的智慧
Arch Linux 中文论坛

我的vimrc: https://git.io/vimrc


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 请教tar: 您不能指定超过一个“-Acdtrux”或是“--test-label”外的选项
帖子发表于 : 2011-05-05 11:24 

注册: 2011-05-03 18:00
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
你确定你的权限没问题?[/quote]
呵呵,谢谢你之前的解答啊,确实开始最大的问题就是没有大写c ,我后来又试了一下是没有加sudo ,是这个的问题。再次感谢一下!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译