配置Eric5 过程中 无法安装QScintilla

Python/PHP/Perl 开发与设计
回复
buptwugh
帖子: 1
注册时间: 2010-10-25 22:56
送出感谢: 0
接收感谢: 0

配置Eric5 过程中 无法安装QScintilla

#1

帖子 buptwugh » 2011-05-12 19:04

下面的报告是我在安装QScintilla时给出来的,一直没成功
wugh@wugh-laptop:~/download/QScintilla-gpl-2.5.1/Python$ python3 configure.py
QScintilla 2.5.1 is being used.
PyQt 4.8.4 is being used.
Qt v4.7.0 free edition is being used.
SIP 4.12.2 is being used.
The QScintilla module will be installed in
/usr/lib/python3.1/dist-packages/PyQt4.
The QScintilla API file will be installed in /usr/share/qt4/qsci/api/python.
The QScintilla .sip files will be installed in /usr/share/sip/PyQt4.
The QScintilla module is being built with generated docstrings.
The QScintilla module is being built with 'protected' redefined as 'public'.
Generating the C++ source for the Qsci module...
sip: sip/qscimod4.sip:31: syntax error
Error: Unable to create the C++ code.

错误应该出在The QScintilla module is being built with generated docstrings.
The QScintilla module is being built with 'protected' redefined as 'public'.
今天在网上搜了一下午也没找到解决方法,求高手帮忙解决问题。。。。
回复

回到 “Python/Php/Perl”