当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : A question about install egg file on ubuntu10.10
帖子发表于 : 2011-05-24 13:51 

注册: 2011-05-05 16:38
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
Hi,Everyone,

I have got two egg format files <birdsuite-1.0-py2.5.egg and mpgutils-0.7-py2.5.egg> ,and intended to install on my ubuntu 10.10 platform.

Following the instructions googled on the web,the steps as follows:
1>sudo apt-get install python-setuptools
then cd to the directory contains the two egg files
2>sudo easy_install birdsuite-1.0-py2.5.egg
whereas the output came out to be :

bhli@ubuntu:~/EXEDIR$ sudo easy_install birdsuite-1.0-py2.5.egg
install_dir /usr/local/lib/python2.6/dist-packages/
Processing birdsuite-1.0-py2.5.egg
creating /usr/local/lib/python2.6/dist-packages/birdsuite-1.0-py2.5.egg
Extracting birdsuite-1.0-py2.5.egg to /usr/local/lib/python2.6/dist-packages
Adding birdsuite 1.0 to easy-install.pth file
Installing cn_locus_summarize script to /usr/local/bin
Installing cn_create_exclude_list script to /usr/local/bin
Installing cn_probeset_summarize script to /usr/local/bin
Installing birdsuite_report script to /usr/local/bin
Installing birdseedqc script to /usr/local/bin
Installing cn_annotate_allele_summary script to /usr/local/bin
Installing initializeCNGaussians script to /usr/local/bin
Installing post_birdseye script to /usr/local/bin
Installing pre_birdseye script to /usr/local/bin
Installing birdsuite_qc script to /usr/local/bin
Installing cn_create_illumnia_exclude_list script to /usr/local/bin

Installed /usr/local/lib/python2.6/dist-packages/birdsuite-1.0-py2.5.egg
Processing dependencies for birdsuite==1.0
Searching for birdsuite==1.0
Reading http://pypi.python.org/simple/birdsuite/
No local packages or download links found for birdsuite==1.0
error: Could not find suitable distribution for Requirement.parse('birdsuite==1.0')

1>what is the matter ?and where i am wrong ?
2>whether or not the egg files that are in zip format can be installed ?
3>what prerequisites should be required while installing egg file ?
4>Another one more question:
when installing a software ,the instructions require install python packages ,and I install the python on ubuntu10.10 by command:
sudo apt-get install python
How can I know the python path is correctly set or not? and Python and the pythoninstaller are the same software or not ?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: A question about install egg file on ubuntu10.10
帖子发表于 : 2011-05-24 19:43 
头像

注册: 2007-03-01 20:46
帖子: 2393
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
There's nothing wrong with your system, it's the egg file that's causing the problem...

Presumably, the egg file contains a configuration file that says it depends on birdsuite version 1.0, which is itself and it's wrong! Since it's not in the Pypi website, it's not installed. However, the installation for your birdsuite package (i.e. the egg file) has already completed, you could try it out by importing the library or executing some of its scripts.

:em11


页首
 用户资料  
 
3 楼 
 文章标题 : Re: A question about install egg file on ubuntu10.10
帖子发表于 : 2011-05-24 19:44 
头像

注册: 2010-06-16 1:05
帖子: 14668
地址: Tencent
系统: Mac OS X
送出感谢: 1
接收感谢: 153
偶的神啊,完全看不懂 :em19 :em19


_________________
twitter求fo:http://twitter.com/maplebeats
博客求踩:http://maplebeats.com


页首
 用户资料  
 
4 楼 
 文章标题 : Re: A question about install egg file on ubuntu10.10
帖子发表于 : 2011-05-25 22:18 

注册: 2011-05-05 16:38
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
anticlockwise 写道:
There's nothing wrong with your system, it's the egg file that's causing the problem...

Presumably, the egg file contains a configuration file that says it depends on birdsuite version 1.0, which is itself and it's wrong! Since it's not in the Pypi website, it's not installed. However, the installation for your birdsuite package (i.e. the egg file) has already completed, you could try it out by importing the library or executing some of its scripts.

:em11


Much obliged.

I am a newbie on ubuntu, and it took me 3 weeks to learn installing the software called birdsuite http://www.broadinstitute.org/science/p ... te-install
but untill now it still cannot run correctly.
Have you ever used this software ?
I have a request ,could you please help me to install this software if possible?
Maybe this will make you to spare and waste some time to read the installation instructions.
Can you add my QQ number :446743893 ?and we can detail about the installation ?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: A question about install egg file on ubuntu10.10
帖子发表于 : 2011-05-25 23:23 

注册: 2011-05-05 16:38
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
anticlockwise 写道:
There's nothing wrong with your system, it's the egg file that's causing the problem...

Presumably, the egg file contains a configuration file that says it depends on birdsuite version 1.0, which is itself and it's wrong! Since it's not in the Pypi website, it's not installed. However, the installation for your birdsuite package (i.e. the egg file) has already completed, you could try it out by importing the library or executing some of its scripts.

:em11


These are the details.

After installing a 64-bit ubuntu10.10 on a window XP hard disk.
1>I installed the JAVA by the following steps:

a)sudo add-apt-repository "deb http://archive.canonical.com/ubuntu maverick partner"
b)sudo apt-get update
c)sudo apt-get install sun-java6-jre sun-java6-jdk sun-java6-plugin
d)java -version
e)sudo update-alternatives --config java

2>then install the python 2.6 and numpy python package

sudo apt-get install python
sudo apt-get install numpy-python
sudo apt-get install scipy-python

3>install R and mclust R package

sudo apt-get install r-base
sudo R CMD INSTALL mclust_3.4.8.tar.gz

4>then begin the installation
a)Create a directory called EXEDIR on /home/bhli,and Unpack birdsuite_executables_1.5.5.tgz into EXEDIR.
b)copy the 64-bit version of apt-probeset-summarize into EXEDIR, with the name apt-probeset-summarize.64
c)Run the following commands:
R CMD INSTALL -l EXEDIR EXEDIR/broadgap.utils_1.0.tar.gz
(Before running this command,a little change have made to the broadgap.utils_1.0.tar.gz)
R CMD INSTALL -l EXEDIR EXEDIR/broadgap.cnputils_1.0.tar.gz
R CMD INSTALL -l EXEDIR EXEDIR/broadgap.canary_1.0.tar.gz
d)Install Matlab compiled runtime(and this step is ok)
e)Create a directory called METADATADIR on /home/bhli,and Unpack birdsuite_metadata_executables_1.5.5.tgz into METADATADIR.
f)Copy the following files from the Affymetrix library bundle (genomewidesnp6_libraryfile.zip) into METADATADIR: GenomeWideSNP_6.Full.cdf, GenomeWideSNP_6.specialSNPs.
g)Copy GenomeWideSNP_6.cdf into METADATADIR.
Copy apt-geno-qc (from APT) into EXEDIR.
h)Create a directory (TESTDIR) and unpack birdsuite_inputs_1.0.tgz there.
cd to TESTDIR.
Run the following command:

bhli@ubuntu:~/TESTDIR$ ~/EXEDIR/birdsuite.sh --basename=test --exeDir=/home/bhli/EXEDIR/ --metadataDir=/home/bhli/METADATADIR/ --chipType=GenomeWideSNP_6 --genderFile=test.gender --celFiles=test.cels --noLsf --apt_probeset_summarize.force --outputDir=output

+ unset DISPLAY
+ export MCR_INHIBIT_CTF_LOCK=1
+ MCR_INHIBIT_CTF_LOCK=1
++ /home/bhli/EXEDIR/getAbsPath /home/bhli/EXEDIR
+ exedir=/home/bhli/EXEDIR
+ export R_LIBS=/home/bhli/EXEDIR:
+ R_LIBS=/home/bhli/EXEDIR:
+ '[' -n 1 ']'
+ exedir_args=--exeDir=/home/bhli/EXEDIR
+ java -jar /home/bhli/EXEDIR/Birdsuite.jar --exeDir=/home/bhli/EXEDIR --basename=test --exeDir=/home/bhli/EXEDIR/ --metadataDir=/home/bhli/METADATADIR/ --chipType=GenomeWideSNP_6 --genderFile=test.gender --celFiles=test.cels --noLsf --apt_probeset_summarize.force --outputDir=output
Newer version of birdsuite available. Version running is 1.5.5 latest version is 1.5.2
Fri May 20 14:44:10 CST 2011 Calling /home/bhli/EXEDIR/apt-probeset-summarize.sh -a quant-norm.target=1000,pm-only,plier.optmethod=1,expr.genotype=true -o output --cdf-file /home/bhli/METADATADIR/GenomeWideSNP_6.Full.cdf --probeset-ids /home/bhli/METADATADIR/GenomeWideSNP_6.birdsuite_probelist --mem-usage 4000 --block-size 0 --precision 2 --force cel/GIGAS_g_GAINmixHapMapAffy2_GenomeWideEx_6_A01_31218.CEL cel/GIGAS_g_GAINmixHapMapAffy2_GenomeWideEx_6_A02_31234.CEL cel/GIGAS_g_GAINmixHapMapAffy2_GenomeWideEx_6_A03_31250.CEL cel/GIGAS_g_GAINmixHapMapAffy2_GenomeWideEx_6_A04_31266.CEL cel/GIGAS_g_GAINmixHapMapAffy2_GenomeWideEx_6_A05_31282.CEL cel/GIGAS_g_GAINmixHapMapAffy2_GenomeWideEx_6_A06_31298.CEL cel/GIGAS_g_GAINmixHapMapAffy2_GenomeWideEx_6_A07_31314.CEL cel/GIGAS_g_GAINmixHapMapAffy2_GenomeWideEx_6_A08_31330.CEL
Opening cdf file: GenomeWideSNP_6.Full.cdf
Expecting 1 iteration.
Doing iteration: 1
Opening cdf file: GenomeWideSNP_6.Full.cdf
Loading 1842537 probesets and 6675129 probes.
Reading 8 cel filesDone.
Processing Probesets......................Done.
Flushing output reporters. Finalizing output.
Done.
Cleaning up.
Done.
Run took approximately: 3.33 minutes.
Fri May 20 14:47:30 CST 2011 Done /home/bhli/EXEDIR/apt-probeset-summarize.sh
Fri May 20 14:47:30 CST 2011 Calling /home/bhli/EXEDIR/cn_annotate_allele_summary --probe_locus /home/bhli/METADATADIR/GenomeWideSNP_6.hg18.probe_locus -o output/test.annotated_summary -t output --summary output/test.allele_summary
Exception in thread "main" edu.mit.broad.mpgcore.exception.MPGRuntimeException: java.lang.reflect.InvocationTargetException
at edu.mit.broad.espcore.apps.affy.BirdSuite.run(BirdSuite.java:401)
at edu.mit.broad.espcore.apps.affy.BirdSuite.main(BirdSuite.java:296)
Caused by: java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at edu.mit.broad.espcore.apps.affy.BirdSuite.run(BirdSuite.java:396)
... 1 more
Caused by: edu.mit.broad.mpgcore.exception.MPGRuntimeException: java.io.IOException: Cannot run program "/home/bhli/EXEDIR/cn_annotate_allele_summary": java.io.IOException: error=2, No such file or directory
at edu.mit.broad.espcore.apps.affy.BirdSuite.execWithStdOutputs(BirdSuite.java:359)
at edu.mit.broad.espcore.apps.affy.BirdSuite.annotate_allele_summaries(BirdSuite.java:478)
... 6 more
Caused by: java.io.IOException: Cannot run program "/home/bhli/EXEDIR/cn_annotate_allele_summary": java.io.IOException: error=2, No such file or directory
at java.lang.ProcessBuilder.start(ProcessBuilder.java:460)
at java.lang.Runtime.exec(Runtime.java:593)
at edu.mit.broad.espcore.apps.affy.BirdSuite.execWithStdOutputs(BirdSuite.java:335)
... 7 more
Caused by: java.io.IOException: java.io.IOException: error=2, No such file or directory
at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
at java.lang.ProcessImpl.start(ProcessImpl.java:65)
at java.lang.ProcessBuilder.start(ProcessBuilder.java:453)
... 9 more


So what might be the problem and what should I do to resolve it?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: A question about install egg file on ubuntu10.10
帖子发表于 : 2011-05-28 14:31 
头像

注册: 2011-02-25 23:23
帖子: 3413
送出感谢: 3
接收感谢: 3
egg…… 这个是安装程序么…… 好蛋疼的后缀 :em03


_________________
The storm of world shall soon vanish
With the days of darknes gone
The sun shall shine upon the ground
To peace shall the world return


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译