perldoc不能使用

Python/PHP/Perl 开发与设计
回复
xki
帖子: 15
注册时间: 2007-01-11 16:41
送出感谢: 0
接收感谢: 0

perldoc不能使用

#1

帖子 xki » 2007-01-14 12:53

当想要使用perldoc查看module的帮助时,出现如下信息:
You need to install the perl-doc package to use this program
当使用apt-get install perl-doc时,又提示:
perl-doc: 依赖: perl (>= 5.8.7-1) 但是它将不会被安装

这个该怎么办阿?不能连perldoc都不用吧
tt2nn
帖子: 205
注册时间: 2007-01-15 9:45
送出感谢: 0
接收感谢: 0

#2

帖子 tt2nn » 2007-02-28 8:53

应该是你的perl的版本过旧了,你试下用perl -v看看版本,如果不是5.8.7的就要连个perl也升升级吧。
lonelyair
帖子: 23
注册时间: 2007-03-13 22:57
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 lonelyair » 2007-03-25 19:54

同样的问题:
akang@akang:~/perl$ perl -v

This is perl, v5.8.7 built for i486-linux-gnu-thread-multi
(with 1 registered patch, see perl -V for more detail)

Copyright 1987-2005, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'. If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.
lonelyair
帖子: 23
注册时间: 2007-03-13 22:57
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 lonelyair » 2007-03-26 20:37

lonelyair 写了:同样的问题:
akang@akang:~/perl$ perl -v

This is perl, v5.8.7 built for i486-linux-gnu-thread-multi
(with 1 registered patch, see perl -V for more detail)

Copyright 1987-2005, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'. If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.
sudo apt-get install perl-doc succeed. :twisted: :twisted: :twisted: :twisted: :twisted: :twisted: :twisted: :twisted:
fedorame
帖子: 3
注册时间: 2007-04-17 11:32
送出感谢: 0
接收感谢: 0

#5

帖子 fedorame » 2007-07-20 15:56

我也遇到这个问题了,我的是debian etch。perl是5.8.8的。已经是最新的了。apt-get install perl-doc 无法成功,提示perl-doc: 依赖: perl (>= 5.8.4-1) 但是它将不会被安装.怎么办呢?
foshuochanyu
帖子: 3
注册时间: 2009-02-19 21:34
送出感谢: 0
接收感谢: 0

Re: perldoc不能使用

#6

帖子 foshuochanyu » 2009-04-16 15:39

我使用ubuntu是8.1,sudo apt-get install perl-doc
可以安装perldoc。
回复

回到 “Python/Php/Perl”