[问题]我编译的gimp 2.3.3 python 的 plugins 都用不起 [已解决]

Python/PHP/Perl 开发与设计
回复
头像
id_sonic
帖子: 339
注册时间: 2005-04-08 18:08
来自: Chongqing
送出感谢: 0
接收感谢: 0
联系:

[问题]我编译的gimp 2.3.3 python 的 plugins 都用不起 [已解决]

#1

帖子 id_sonic » 2005-12-20 17:19

安装到 /opt/gimp 下
系统: ubuntulinux 5.04

代码: 全选


$sudo ./configure --prefix=/opt/gimp --disable-print && make && make install

比如我使用 addfog 这个python-gimp 插件: 可以出现插件的画面,但是按“确定”之后却不能正确执行。

代码: 全选

woody@ubuntu:~$ bin/gimp2.3
This is a development version of The GIMP.
Debug messages may appear here.

Traceback (most recent call last):
  File "/opt/gimp/lib/gimp/2.0/python/gimpfu.py", line 503, in response
    dialog.res = run_script(params)
  File "/opt/gimp/lib/gimp/2.0/python/gimpfu.py", line 269, in run_script
    return apply(function, params)
  File "/opt/gimp/lib/gimp/2.0/plug-ins/foggify.py", line 40, in python_foggify
    pdb.plug_in_plasma(img, mask, int(time.time()), turbulence)
TypeError: wrong number of parameters
其中 bin/gimp2.3 内容为

代码: 全选

#!/bin/sh

PATH=/opt/gimp/bin:$PATH
export PATH
LD_LIBRARY_PATH=/opt/gimp/lib:/opt/gimp/lib/gimp/2.0/python
export LD_LIBRARY_PATH

/opt/gimp/bin/gimp-2.3 "$@"
所有的python-gimp插件都会出现这样的情况。
目前是 tinkpad r400 上的 debian 用户
my blog Trust Dating
回复

回到 “Python/Php/Perl”