[问题]安装pygtk-2.0.0的问题,很严重,怎么半????

Python/PHP/Perl 开发与设计
回复
头像
leran0222
帖子: 105
注册时间: 2007-05-12 0:13
送出感谢: 0
接收感谢: 0

[问题]安装pygtk-2.0.0的问题,很严重,怎么半????

#1

帖子 leran0222 » 2007-10-29 22:48

第一步:./configure
没有问题
第二步:make
问题如下:
…………………………………………
…………………………………………
gtk.c: In function '_wrap_gtk_vbutton_box_set_layout_default':
gtk.c:36474: warning: dereferencing type-punned pointer will break strict-aliasing rules
gtk.c: In function '_wrap_gtk_widget_set_default_direction':
gtk.c:36570: warning: dereferencing type-punned pointer will break strict-aliasing rules
make[2]: *** [_gtk_la-gtk.lo] Error 1
make[2]: Leaving directory `/home/leran0222/Downloads/pygtk-2.0.0/gtk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/leran0222/Downloads/pygtk-2.0.0'
make: *** [all] Error 2

然后就退出不再make了,各位高手帮帮忙,怎么半???????????????????
peikona
帖子: 42
注册时间: 2006-08-27 16:23
送出感谢: 0
接收感谢: 0

Re: [问题]安装pygtk-2.0.0的问题,很严重,怎么半????

#2

帖子 peikona » 2008-01-01 11:38

leran0222 写了:第一步:./configure
没有问题
第二步:make
问题如下:
…………………………………………
…………………………………………
gtk.c: In function '_wrap_gtk_vbutton_box_set_layout_default':
gtk.c:36474: warning: dereferencing type-punned pointer will break strict-aliasing rules
gtk.c: In function '_wrap_gtk_widget_set_default_direction':
gtk.c:36570: warning: dereferencing type-punned pointer will break strict-aliasing rules
make[2]: *** [_gtk_la-gtk.lo] Error 1
make[2]: Leaving directory `/home/leran0222/Downloads/pygtk-2.0.0/gtk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/leran0222/Downloads/pygtk-2.0.0'
make: *** [all] Error 2

然后就退出不再make了,各位高手帮帮忙,怎么半???????????????????

直接用新立得搜索pygtk,看到是gtk到python的绑定就把它装上,也没几个软件。不用自己编译这么麻烦。
回复

回到 “Python/Php/Perl”