当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]ubuntu7.10 安装rails出错,请教!
帖子发表于 : 2007-12-17 23:34 
头像

注册: 2007-05-29 21:58
帖子: 164
地址: 大连
送出感谢: 0 次
接收感谢: 0 次
错误信息如下:请有经验者帮帮忙,我刚刚开始学ROR,什么都不懂,大家帮帮忙吧,谢谢了!!!!
代码:
sincerity@SINCERITY:~$ ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [i686-linux]
sincerity@SINCERITY:~$ gem -v
0.9.5
sincerity@SINCERITY:~$ gem install rails --include-dependencies
/program/MyPro/ruby/lib/ruby/1.8/i686-linux/digest/md5.so: /program/MyPro/ruby/lib/ruby/1.8/i686-linux/digest/md5.so: undefined symbol: rb_Digest_MD5_Init - /program/MyPro/ruby/lib/ruby/1.8/i686-linux/digest/md5.so (LoadError)
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/digest/md5.rb:8
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:12
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/format.rb:9
         ... 14 levels...
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:103:in `process_args'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:74:in `run'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:39:in `run'
        from /program/MyPro/ruby/bin/gem:22
sincerity@SINCERITY:~$



_________________
理论上菜鸟也是鸟啊!
那就是说我是可以飞地,但是如果真飞不起来,我就去当鸵鸟...
http://www.netyi.net/in.asp?id=sincere1809


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-19 12:01 
头像

注册: 2007-05-29 21:58
帖子: 164
地址: 大连
送出感谢: 0 次
接收感谢: 0 次
/program/MyPro/ruby/lib/ruby/1.8/i686-linux/digest/md5.so
这个文件我的安装目录下存在啊,为什么会出现这个错误
能给讲解一下吗


_________________
理论上菜鸟也是鸟啊!
那就是说我是可以飞地,但是如果真飞不起来,我就去当鸵鸟...
http://www.netyi.net/in.asp?id=sincere1809


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [问题]ubuntu7.10 安装rails出错,请教!
帖子发表于 : 2007-12-22 19:04 

注册: 2007-03-24 9:08
帖子: 444
地址: 青岛
送出感谢: 0 次
接收感谢: 0 次
jiening1017 写道:
错误信息如下:请有经验者帮帮忙,我刚刚开始学ROR,什么都不懂,大家帮帮忙吧,谢谢了!!!!
代码:
sincerity@SINCERITY:~$ ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [i686-linux]
sincerity@SINCERITY:~$ gem -v
0.9.5
sincerity@SINCERITY:~$ gem install rails --include-dependencies
/program/MyPro/ruby/lib/ruby/1.8/i686-linux/digest/md5.so: /program/MyPro/ruby/lib/ruby/1.8/i686-linux/digest/md5.so: undefined symbol: rb_Digest_MD5_Init - /program/MyPro/ruby/lib/ruby/1.8/i686-linux/digest/md5.so (LoadError)
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/digest/md5.rb:8
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:12
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/format.rb:9
         ... 14 levels...
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:103:in `process_args'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:74:in `run'
        from /program/MyPro/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:39:in `run'
        from /program/MyPro/ruby/bin/gem:22
sincerity@SINCERITY:~$



不太知道,自己编译的吧,再编一次看看……我自己编译的时候少一个zlib……


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-23 10:33 
头像

注册: 2007-05-29 21:58
帖子: 164
地址: 大连
送出感谢: 0 次
接收感谢: 0 次
引用:
不太知道,自己编译的吧,再编一次看看……我自己编译的时候少一个zlib……


其实我都编译好多此了,我开始的时候也是少zlib,后来我按照网上的方法把/ruby/ext/setup文件有的地方的注释去掉了,然后编译的,就有zlib了,但是就出现上面的问题了。但是问题是,那个该死的文件我的安装目录里边有啊?为什么会加载错误呢?


_________________
理论上菜鸟也是鸟啊!
那就是说我是可以飞地,但是如果真飞不起来,我就去当鸵鸟...
http://www.netyi.net/in.asp?id=sincere1809


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-12-23 12:05 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
https://help.ubuntu.com/7.10/server/C/r ... rails.html

没事去官方网站看看吧, 别瞎折腾.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译