[问题]8.04 ALpha4 能不能安装VM WORKSTATION6.02

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
头像
Zeal0t
帖子: 95
注册时间: 2007-11-18 21:19
送出感谢: 0
接收感谢: 0

[问题]8.04 ALpha4 能不能安装VM WORKSTATION6.02

#1

帖子 Zeal0t » 2008-02-08 18:19

安装到最后出了一大堆错,是不是6.02不支持8.04???sudo apt-get install linux-headers-`uname -r`已经安装了

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.24-5-rt/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config1/vmmon-only'
make -C /lib/modules/2.6.24-5-rt/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-5-rt'
CC [M] /tmp/vmware-config1/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config1/vmmon-only/./include/vmware.h:25,
from /tmp/vmware-config1/vmmon-only/linux/driver.c:83:
/tmp/vmware-config1/vmmon-only/./include/vm_basic_types.h:170: 错误: 与‘uintptr_t’类型冲突
include/linux/types.h:40: 错误: ‘uintptr_t’的上一个声明在此
在包含自 /tmp/vmware-config1/vmmon-only/./include/x86.h:23 的文件中,
从 /tmp/vmware-config1/vmmon-only/linux/driver.h:15,
从 /tmp/vmware-config1/vmmon-only/linux/driver.c:84:
/tmp/vmware-config1/vmmon-only/./include/x86cpuid.h:383:1: 警告: “BIT_MASK”重定义
在包含自 include/linux/kernel.h:15 的文件中,
从 /tmp/vmware-config1/vmmon-only/linux/driver.c:11:
include/linux/bitops.h:7:1: 警告: 这是先前定义的位置
在包含自 /tmp/vmware-config1/vmmon-only/./include/vmci_kernel_defs.h:26 的文件中,
从 /tmp/vmware-config1/vmmon-only/./common/vmciContext.h:19,
从 /tmp/vmware-config1/vmmon-only/linux/driver.h:21,
从 /tmp/vmware-config1/vmmon-only/linux/driver.c:84:
/tmp/vmware-config1/vmmon-only/./include/compat_wait.h:37:5: 警告: “VMW_HAVE_EPOLL”未定义
/tmp/vmware-config1/vmmon-only/./include/compat_wait.h:43:5: 警告: “VMW_HAVE_EPOLL”未定义
In file included from /tmp/vmware-config1/vmmon-only/./include/vmci_kernel_defs.h:26,
from /tmp/vmware-config1/vmmon-only/./common/vmciContext.h:19,
from /tmp/vmware-config1/vmmon-only/linux/driver.h:21,
from /tmp/vmware-config1/vmmon-only/linux/driver.c:84:
/tmp/vmware-config1/vmmon-only/./include/compat_wait.h:60: 错误: 与‘poll_initwait’类型冲突
include/linux/poll.h:65: 错误: ‘poll_initwait’的上一个声明在此
/tmp/vmware-config1/vmmon-only/linux/driver.c:198: 警告: 从不兼容的指针类型初始化
make[2]: *** [/tmp/vmware-config1/vmmon-only/linux/driver.o] 错误 1
make[1]: *** [_module_/tmp/vmware-config1/vmmon-only] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-5-rt'
make: *** [vmmon.ko] 错误 2
make: Leaving directory `/tmp/vmware-config1/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference ... linux.html".

Execution aborted.
头像
Zeal0t
帖子: 95
注册时间: 2007-11-18 21:19
送出感谢: 0
接收感谢: 0

#2

帖子 Zeal0t » 2008-02-08 19:49

没人知道吗?不知道也回一下嘛....
nomcoych
帖子: 179
注册时间: 2007-06-27 23:43
送出感谢: 0
接收感谢: 0

#3

帖子 nomcoych » 2008-02-10 17:31

呵呵,我也遇到问题了,不知道怎么解决。
kobecater000
帖子: 194
注册时间: 2006-05-04 20:00
送出感谢: 0
接收感谢: 0

#4

帖子 kobecater000 » 2008-02-18 18:42

由于是2.6.24的kernel,参考http://linuxtoy.org/archives/vmware-and-kernel-2624.html
starster888
帖子: 98
注册时间: 2007-03-19 19:15
送出感谢: 0
接收感谢: 0

#5

帖子 starster888 » 2008-04-27 13:14

要下一个名为vmware-any-any-update-116.tgz的补丁,安装就可以了。看好了是-116----这是版本,我先前下了一个1vmware-any-any-update-109.tgz的,就不合适。

下载地址:http://linuxtoy.org/files/vmware-any-any-update-116.tgz

这是kobecater000兄提到的http://linuxtoy.org/archives/vmware-and-kernel-2624.html
上的原文

昨天,系统将内核升至 2.6.24,除了 VMware Server 停止响应外,其他一切尚好。根据以往的经验,只需重新配置 VMware Server,并编译适应新内核的 VMware 模块即可。于是遂调用 VMware Server 配置程序 vmware-config.pl,无奈在编译模块时却无法通过。

后想起原来在安装 VMware Server 时使用过 VMware-any-to-any-update 补丁,就找来最新版一试,果然灵验。该 VMware-any-to-any-update 最新版为 116,可从这里下载。其使用方法如下:

tar zxvf vmware-any-any-update-116.tgz
cd vmware-any-any-update116/
./runme.pl

在执行补丁操作后,runme.pl 将调用 vmware-config.pl,按提示操作即可,此不赘述。

另外,要补充的是,此 VMware-any-to-any-update 补丁无论对于 VMware Server,还是对于 VMware Workstation 都是适用的。希望以上提及的对遇到同样问题的朋友有所帮助。
头像
zengdesheng
帖子: 92
注册时间: 2006-11-05 10:43
送出感谢: 0
接收感谢: 0

#6

帖子 zengdesheng » 2008-05-26 1:38

顶一下,搞了两天了。终于解决这个问题了。
回复

回到 “虚拟机和虚拟化”