当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : virtualbox 虚拟安装xp启动时出现pause的问题
帖子发表于 : 2008-02-20 0:09 
头像

注册: 2007-07-22 10:40
帖子: 142
送出感谢: 0 次
接收感谢: 1
host是ubuntu7.10,virtualbox 1.5.4,虚拟安装deepin简化版xp,整个安装过程正常。启动xp时,系统会暂停,画面静止,需要移动一下鼠标或者按一下键盘才能继续启动,就像是启动时被Pause一样。
哪个同学有类似经历?怎样解决?
谢谢先了!

(btw,我在网上查过,没找到答案。)


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-02-20 11:10 

注册: 2008-02-05 16:47
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
呵呵,我和你的环境一样,有一次遇到这种问题。

还有另外一个问题更晕。。。XP在使用时,经常停顿,没错是停顿,整个屏幕完全“静止”了,鼠标键盘都没有反应,一般要过n分钟才会开始恢复正常

不知道这是VBOX的通病吗?呵呵


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-02-20 11:57 
头像

注册: 2006-07-29 20:50
帖子: 250
送出感谢: 0 次
接收感谢: 0 次
一直没碰到过,估计是内存调用出问题了,也可能内存制量问题。


_________________
向那些默默支持Ubuntu和Linux的兄弟致敬!
我的百度空间:
http://hi.baidu.com/%B0%A2%CC%B8


页首
 用户资料  
 
4 楼 
 文章标题 : Re: virtualbox 虚拟安装xp启动时出现pause的问题
帖子发表于 : 2008-02-20 16:12 

注册: 2006-12-30 23:11
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
恩,同样的问题,
1.5.6问题依旧。
VBox的官方论坛也有讨论,
http://forums.virtualbox.org/viewtopic.php?t=2764
解决方法是在Grub的启动参数上添加 nohz=off,
这个选项的解释是
"This option prevents the host Linux to enter the tickless mode. In this mode the kernel timer is programmed in one-shot mode, contrary to the periodic mode which is normally used. VirtualBox currently does not play well with host kernels in one-shot mode. We are working on a solution. Until we fixed it, use this option to restore the old behavior."


souling 写道:
host是ubuntu7.10,virtualbox 1.5.4,虚拟安装deepin简化版xp,整个安装过程正常。启动xp时,系统会暂停,画面静止,需要移动一下鼠标或者按一下键盘才能继续启动,就像是启动时被Pause一样。
哪个同学有类似经历?怎样解决?
谢谢先了!

(btw,我在网上查过,没找到答案。)


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-02-22 14:25 
头像

注册: 2007-07-22 10:40
帖子: 142
送出感谢: 0 次
接收感谢: 1
lanefox 写道:
呵呵,我和你的环境一样,有一次遇到这种问题。

还有另外一个问题更晕。。。XP在使用时,经常停顿,没错是停顿,整个屏幕完全“静止”了,鼠标键盘都没有反应,一般要过n分钟才会开始恢复正常

不知道这是VBOX的通病吗?呵呵


这个问题我也有,在笔记本电脑上经常发生,台式机就没有。
静止时,往往笔记本无线网会断掉并重新连接。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: virtualbox 虚拟安装xp启动时出现pause的问题
帖子发表于 : 2008-02-22 14:55 
头像

注册: 2007-07-22 10:40
帖子: 142
送出感谢: 0 次
接收感谢: 1
[quote="JustTD"]恩,同样的问题,
1.5.6问题依旧。
VBox的官方论坛也有讨论,
http://forums.virtualbox.org/viewtopic.php?t=2764
解决方法是在Grub的启动参数上添加 nohz=off,
这个选项的解释是
"This option prevents the host Linux to enter the tickless mode. In this mode the kernel timer is programmed in one-shot mode, contrary to the periodic mode which is normally used. VirtualBox currently does not play well with host kernels in one-shot mode. We are working on a solution. Until we fixed it, use this option to restore the old behavior."


查看了官方论坛的帖子,好像这个参数不能解决问题。


Hi
thanks for the reply, and sorry for my late rereply Smile... I added the parameter to this line:
# kopt=root=UUID=aac93673-9bfd-4bce-b4b5-7d3b3fb3446d ro nohz=off

And then executed update-grub which appeared to modify the boot.lst further by adding that nohz=off to other lines as well. Correct I guess.

While the timing does appear to behave a bit differently, the clock is still not ticking correctly inside my VM Sad
Any other ideas?


http://forums.virtualbox.org/viewtopic. ... 963ccce2c2


页首
 用户资料  
 
7 楼 
 文章标题 : Re: virtualbox 虚拟安装xp启动时出现pause的问题
帖子发表于 : 2008-02-22 15:48 

注册: 2006-12-30 23:11
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
应该添加到
kernel /boot/vmlinuz-2.6....locale=en_CN的后面成为
kernel /boot/vmlinuz-2.6....locale=en_CN nohz=off
添加在#后面的内容是不起作用的...
上面这个方法在我机器上起作用.


souling 写道:
JustTD 写道:
恩,同样的问题,
1.5.6问题依旧。
VBox的官方论坛也有讨论,
http://forums.virtualbox.org/viewtopic.php?t=2764
解决方法是在Grub的启动参数上添加 nohz=off,
这个选项的解释是
"This option prevents the host Linux to enter the tickless mode. In this mode the kernel timer is programmed in one-shot mode, contrary to the periodic mode which is normally used. VirtualBox currently does not play well with host kernels in one-shot mode. We are working on a solution. Until we fixed it, use this option to restore the old behavior."


查看了官方论坛的帖子,好像这个参数不能解决问题。


Hi
thanks for the reply, and sorry for my late rereply Smile... I added the parameter to this line:
# kopt=root=UUID=aac93673-9bfd-4bce-b4b5-7d3b3fb3446d ro nohz=off

And then executed update-grub which appeared to modify the boot.lst further by adding that nohz=off to other lines as well. Correct I guess.

While the timing does appear to behave a bit differently, the clock is still not ticking correctly inside my VM Sad
Any other ideas?


http://forums.virtualbox.org/viewtopic. ... 963ccce2c2


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译