当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 33 篇帖子 ]  前往页数 1, 2, 3  下一页
作者 内容
1 楼 
 文章标题 : [问题]virtualbox加载建行网银ukey错误
帖子发表于 : 2008-03-08 18:15 
头像

注册: 2008-02-08 22:19
帖子: 241
地址: 漳州
送出感谢: 0 次
接收感谢: 0 次
在virtualbox虚拟了xp,加载建行网银的ukey出错了。
点virtualbox加载usb设备(设备显示为:未知设备)提示如下错误:
(Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR).


Result Code:
0x80004005
Component:
Console
Interface:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}
应该是驱动问题吧,我这个是无驱的ukey啊。建行的握奇ukey)
可能vbuntu不认这个ukey,没有它的驱动吧,有没有办法解决呢?


最后由 kujian 编辑于 2008-03-09 22:00,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-09 17:50 
头像

注册: 2008-02-08 22:19
帖子: 241
地址: 漳州
送出感谢: 0 次
接收感谢: 0 次
没人顶一下啊,我自己来顶顶。
这个问题要是真能解决,那我的xp就让他在虚拟机呆着就好!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-09 22:01 
头像

注册: 2008-02-08 22:19
帖子: 241
地址: 漳州
送出感谢: 0 次
接收感谢: 0 次
进来看的也帮忙顶一下啊,感觉就我一个人在论坛是的,有种孤单的感觉 :oops:


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-10 10:14 

注册: 2007-11-27 22:20
帖子: 444
送出感谢: 0 次
接收感谢: 0 次
没有试过 这个东西 顶


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-10 11:21 
头像

注册: 2008-02-08 22:19
帖子: 241
地址: 漳州
送出感谢: 0 次
接收感谢: 0 次
谢谢,终于有人顶了。我相信很多用网银的朋友都有遇到在ubuntu下的困惑吧


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-10 14:41 

注册: 2006-11-30 18:52
帖子: 133
送出感谢: 0 次
接收感谢: 0 次
如果其他的usb设备在虚拟机中使用正常估计就是虚拟系统的问题,其它的也出错就是你虚拟机usb设置的问题。一般来说只要设置正确,xp下正常的设备虚拟xp中也正常,你尝试打开虚拟机usb权限试试看,我的工行u盾使用就很正常。
此外,不要在“USB设备筛选器里”选上你的usbkey,到时候需要什么usb设备,就直接手动传递给VBox,个人感觉这样比较好,同时如果不行可以试试不选择“enable USB ECHI controller“,我的moto的mpt不选就能驱动,选上反而驱不上。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-12 23:57 
头像

注册: 2008-02-08 22:19
帖子: 241
地址: 漳州
送出感谢: 0 次
接收感谢: 0 次
u盘可以正常使用的,就ukey不能用;我按你说的方法试试。谢谢


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-03-13 0:26 
头像

注册: 2008-02-08 22:19
帖子: 241
地址: 漳州
送出感谢: 0 次
接收感谢: 0 次
还是不行,我抓张图你们帮我看看


附件:
Screenshot-VirtualBox - 错误.png
Screenshot-VirtualBox - 错误.png [ 8.63 KiB | 被浏览 4307 次 ]
页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-03-13 11:49 

注册: 2007-08-24 15:05
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
跟我一样应该是config的问题,因为之前装的7.10是可以用的,没有问题,后来重装了7.10然后导入Vbox的系统镜像就不能用USB了,不管怎么配都不行。提示错误一样


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-03-14 1:26 
头像

注册: 2008-02-08 22:19
帖子: 241
地址: 漳州
送出感谢: 0 次
接收感谢: 0 次
我用u盘可以正常使用,就是用不了建行网银的ukey


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-03-21 16:25 

注册: 2006-03-30 21:04
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
今天使用Vbox 发现这样的错误 [virtualbox访问usb子系统失败] .在晚上找了一下发现问题的主要原因是Vbox对USB不支持.但是想一下以前是支持的啊,看来是7.10取消了Vbox对USB的支持.到晚上转了一圈发现答案还是比较多的.只是看了很多的朋友都是新建usbfs这个新组.然后将用户添加等等一系列的操作.其实发现不用太麻烦

在 /etc/init.d/mountdevsubfs.sh 文件,找到如下内容:


#mkdir -p /dev/bus/usb/.usbfs
#domount usbfs "" /dev/bus/usb/.usbfs
-obusmode=0700,devmode=0600,listmode=0644
#ln -s .usbfs/devices /dev/bus/usb/devices
#mount --rbind /dev/bus/usb /proc/bus/usb

取消最后四行的注释纯盘后.找到Vbox创建的用户组
(cat /etc/group | grep vboxusers)
的ID.如我的是1001.

在/etc/fstab文件最后加上

none /proc/bus/usb usbfs devgid=1001,devmode=664 0 0 .

使vboxusers用户组拥有访问usb设备的权限 .这样重启电脑就可以使用了.其实如果不想重启就如下

sudo mount -vt usbfs none /proc/bus/usb -o devgid=1001,devmode=664 也可以..

注意在虚拟机中使用U盘.应该在主机中 unmount U盘.


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-03-28 21:53 
头像

注册: 2008-02-08 22:19
帖子: 241
地址: 漳州
送出感谢: 0 次
接收感谢: 0 次
问题不是这里啊,我u盘可以正常使用。就是网银的ukey不能用啊


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-04-03 12:11 

注册: 2007-06-18 15:43
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
是否安装了建行的那个驱动包,就是光盘里的那个!


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-04-04 13:44 
头像

注册: 2008-02-08 22:19
帖子: 241
地址: 漳州
送出感谢: 0 次
接收感谢: 0 次
驱动包我在虚拟机的xp系统装了,没有for linux的驱动包。


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-04-04 14:35 
头像

注册: 2005-11-28 12:09
帖子: 555
送出感谢: 0 次
接收感谢: 1
vbox的对宿主的usb支持不是完善的


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 33 篇帖子 ]  前往页数 1, 2, 3  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译