当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装VMware-workstation-6.0.0-45731 出现了问题(已经解决)
帖子发表于 : 2008-04-18 12:44 

注册: 2008-04-16 20:23
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
以下是故障代码!请各位老大们帮忙解决下!

Extracting the sources of the vmmon module.

Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config0/vmmon-only'
make -C /lib/modules/2.6.24-16-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-16-generic'
CC [M] /tmp/vmware-config0/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config0/vmmon-only/./include/vmware.h:25,
from /tmp/vmware-config0/vmmon-only/linux/driver.c:48:
/tmp/vmware-config0/vmmon-only/./include/vm_basic_types.h:170: 错误: 与‘uintptr_t’类型冲突
include/linux/types.h:40: 错误: ‘uintptr_t’的上一个声明在此
在包含自 /tmp/vmware-config0/vmmon-only/./include/x86.h:23 的文件中,
从 /tmp/vmware-config0/vmmon-only/linux/driver.h:15,
从 /tmp/vmware-config0/vmmon-only/linux/driver.c:49:
/tmp/vmware-config0/vmmon-only/./include/x86cpuid.h:381:1: 警告: “BIT_MASK”重定义
在包含自 include/linux/kernel.h:15 的文件中,
从 /tmp/vmware-config0/vmmon-only/linux/driver.c:11:
include/linux/bitops.h:7:1: 警告: 这是先前定义的位置
在包含自 /tmp/vmware-config0/vmmon-only/./include/vmci_kernel_defs.h:26 的文件中,
从 /tmp/vmware-config0/vmmon-only/./common/vmciContext.h:19,
从 /tmp/vmware-config0/vmmon-only/linux/driver.h:21,
从 /tmp/vmware-config0/vmmon-only/linux/driver.c:49:
/tmp/vmware-config0/vmmon-only/./include/compat_wait.h:37:5: 警告: “VMW_HAVE_EPOLL”未定义
/tmp/vmware-config0/vmmon-only/./include/compat_wait.h:43:5: 警告: “VMW_HAVE_EPOLL”未定义
In file included from /tmp/vmware-config0/vmmon-only/./include/vmci_kernel_defs.h:26,
from /tmp/vmware-config0/vmmon-only/./common/vmciContext.h:19,
from /tmp/vmware-config0/vmmon-only/linux/driver.h:21,
from /tmp/vmware-config0/vmmon-only/linux/driver.c:49:
/tmp/vmware-config0/vmmon-only/./include/compat_wait.h:60: 错误: 与‘poll_initwait’类型冲突
include/linux/poll.h:65: 错误: ‘poll_initwait’的上一个声明在此
/tmp/vmware-config0/vmmon-only/linux/driver.c:150: 警告: 从不兼容的指针类型初始化
/tmp/vmware-config0/vmmon-only/linux/driver.c: 在函数‘LinuxDriver_Ioctl’中:
/tmp/vmware-config0/vmmon-only/linux/driver.c:1715: 错误: ‘struct mm_struct’没有名为‘dumpable’的成员
make[2]: *** [/tmp/vmware-config0/vmmon-only/linux/driver.o] 错误 1
make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-16-generic'
make: *** [vmmon.ko] 错误 2
make: Leaving directory `/tmp/vmware-config0/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.

我 装了6.0.3的版本了,就是序列号找不到


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-26 13:55 
头像

注册: 2008-04-18 17:29
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
我安装时也遇到这个问题了, 你是怎么解决的?
谢谢~


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-27 8:50 
头像

注册: 2008-01-29 20:16
帖子: 43
地址: 苏州
送出感谢: 0 次
接收感谢: 0 次
i agree so much


_________________
Dfive Team,我们一直在努力


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-29 12:02 
头像

注册: 2006-11-30 21:09
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
遇到同样问题,请教楼主是怎么解决的?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-30 10:44 
头像

注册: 2006-11-30 21:09
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
已解决。
下载安装了vmware-any-any-update-116.tgz.rar


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译