[已解决]Vbox里USB KEY的问题

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
mauricze
帖子: 87
注册时间: 2007-12-24 12:58
送出感谢: 0
接收感谢: 0

[已解决]Vbox里USB KEY的问题

#1

帖子 mauricze » 2008-04-28 14:57

我完全照着以下这贴的步骤做的
http://forum.ubuntu.org.cn/viewtopic.php?t=89142
但是Vbox好像还是有问题,能认出这个USB KEY,但不能挂载,设备中显示的都是灰色的,为什么啊?
附件
Screenshot.png
上次由 mauricze 在 2008-04-28 16:33,总共编辑 1 次。
mauricze
帖子: 87
注册时间: 2007-12-24 12:58
送出感谢: 0
接收感谢: 0

#2

帖子 mauricze » 2008-04-28 15:33

well, has to run vbox as root
以root启动VBOX就可以了
有什么办法可以$普通用户方式运行并获得permission?
mauricze
帖子: 87
注册时间: 2007-12-24 12:58
送出感谢: 0
接收感谢: 0

#3

帖子 mauricze » 2008-04-28 16:23

彻底解决了
顶楼那连接里的方法有点画蛇添足
直接在/etc/fstab里添加
none /proc/bus/usb usbfs devgid=46,devmode=664 0 0
一行就行了,不用添加什么组,因为缺省状态下,你的user就在这个plugdev组里的
添加后需要重启
不重启的话
sudo mount -vt usbfs none /proc/bus/usb -o devgid=46,devmode=664
即可

参考
http://forums.virtualbox.org/viewtopic. ... 963b5eb7c6
mauricze
帖子: 87
注册时间: 2007-12-24 12:58
送出感谢: 0
接收感谢: 0

#4

帖子 mauricze » 2008-04-28 16:32

2001xk
帖子: 13
注册时间: 2007-01-30 22:54
送出感谢: 0
接收感谢: 0

#5

帖子 2001xk » 2008-04-30 22:22

This machine does not have any snapshots.


返回 代码:
0x80004005
组件:
Machine
界面:
IMachine {31f7169f-14da-4c55-8cb6-a3665186e35e}
被召者 RC:
0x80004001

添加了用户为vboxusers组和修改/etc/fstab还是不行。
我这个是OSE版的,难道不支持USB??
webcgo
帖子: 101
注册时间: 2008-04-13 13:58
送出感谢: 0
接收感谢: 0

#6

帖子 webcgo » 2008-05-09 19:55

我看ose版本真的不能用usb,我真郁闷
头像
newfansgg
帖子: 140
注册时间: 2008-06-09 12:06
送出感谢: 0
接收感谢: 0

#7

帖子 newfansgg » 2008-06-30 19:45

mauricze 写了:彻底解决了
顶楼那连接里的方法有点画蛇添足
直接在/etc/fstab里添加
none /proc/bus/usb usbfs devgid=46,devmode=664 0 0
一行就行了,不用添加什么组,因为缺省状态下,你的user就在这个plugdev组里的
添加后需要重启
不重启的话
sudo mount -vt usbfs none /proc/bus/usb -o devgid=46,devmode=664
即可

参考
http://forums.virtualbox.org/viewtopic. ... 963b5eb7c6



天呢,终于解决了,sudo mount -vt usbfs none /proc/bus/usb -o devgid=46,devmode=664 执行这个后,那个安装usb设置的选项就不灰了 :lol:
tianyi
帖子: 114
注册时间: 2008-01-19 15:10
送出感谢: 0
接收感谢: 0

#8

帖子 tianyi » 2008-07-07 19:34

试试,要用网银。。。
plumx
帖子: 37
注册时间: 2006-12-03 0:51
送出感谢: 0
接收感谢: 0

Re:

#9

帖子 plumx » 2010-02-18 13:42

newfansgg 写了:
mauricze 写了:彻底解决了
顶楼那连接里的方法有点画蛇添足
直接在/etc/fstab里添加
none /proc/bus/usb usbfs devgid=46,devmode=664 0 0
一行就行了,不用添加什么组,因为缺省状态下,你的user就在这个plugdev组里的
添加后需要重启
不重启的话
sudo mount -vt usbfs none /proc/bus/usb -o devgid=46,devmode=664
即可

参考
http://forums.virtualbox.org/viewtopic. ... 963b5eb7c6

天呢,终于解决了,sudo mount -vt usbfs none /proc/bus/usb -o devgid=46,devmode=664 执行这个后,那个安装usb设置的选项就不灰了 :lol:

请问,除了以上设置以外,您还设置了其他什么地方?我的提示/proc/bus/usb挂载点不存在。
头像
czjl
帖子: 765
注册时间: 2008-07-28 10:02
送出感谢: 1 次
接收感谢: 0

Re: [已解决]Vbox里USB KEY的问题

#10

帖子 czjl » 2010-02-20 11:42

plumx 写了: 请问,除了以上设置以外,您还设置了其他什么地方?我的提示/proc/bus/usb挂载点不存在。
最新版不需要这么麻烦。
打开“用户和组”,将用户名添加到vboxusers组里。打开virtualbox,虚拟机设置里,USB设备添加一下就可以了。上午刚刚添加了工行U盾。成功支付。
plumx
帖子: 37
注册时间: 2006-12-03 0:51
送出感谢: 0
接收感谢: 0

Re: [已解决]Vbox里USB KEY的问题

#11

帖子 plumx » 2010-02-20 16:41

czjl 写了:
plumx 写了: 请问,除了以上设置以外,您还设置了其他什么地方?我的提示/proc/bus/usb挂载点不存在。
最新版不需要这么麻烦。
打开“用户和组”,将用户名添加到vboxusers组里。打开virtualbox,虚拟机设置里,USB设备添加一下就可以了。上午刚刚添加了工行U盾。成功支付。

图片

按照如上所示,我已经成功添加了当前用户名到vboxusers里面,同时,为以防万一,也将当前用户名添加到了usbfs组里面,但是还是在运行“sudo mount -vt usbfs none /proc/bus/usb -o devgid=46,devmode=664”时提示“挂载点/proc/bus/usb不存在。“
手动进入/proc/bus/这个文件夹查看,却发现只有input和pci两个文件夹,并没有usb文件夹。重启UBUNTU后,现象仍然存在。

在UBUNTU地下能看见U盾的信息,在虚拟XP里面的硬件信息里,也能看见USB驱动下面的U盾信息。

我的VBOX版本是3.1.4 r57640,从官网下载的deb包。

请问一下,问题可能出在什么地方?
头像
czjl
帖子: 765
注册时间: 2008-07-28 10:02
送出感谢: 1 次
接收感谢: 0

Re: [已解决]Vbox里USB KEY的问题

#12

帖子 czjl » 2010-02-20 20:24

plumx 写了: 请问一下,问题可能出在什么地方?
不好意思,我只是按照10楼简单地设置了一下就可以用了。没有运行“sudo mount -vt usbfs none /proc/bus/usb -o devgid=46,devmode=664”等,所以无法解答这个问题。
day2up
帖子: 59
注册时间: 2009-04-14 23:51
送出感谢: 1 次
接收感谢: 0

Re: [已解决]Vbox里USB KEY的问题

#13

帖子 day2up » 2010-05-18 15:54

plumx 写了:
czjl 写了:
plumx 写了: 请问,除了以上设置以外,您还设置了其他什么地方?我的提示/proc/bus/usb挂载点不存在。
最新版不需要这么麻烦。
打开“用户和组”,将用户名添加到vboxusers组里。打开virtualbox,虚拟机设置里,USB设备添加一下就可以了。上午刚刚添加了工行U盾。成功支付。

图片

按照如上所示,我已经成功添加了当前用户名到vboxusers里面,同时,为以防万一,也将当前用户名添加到了usbfs组里面,但是还是在运行“sudo mount -vt usbfs none /proc/bus/usb -o devgid=46,devmode=664”时提示“挂载点/proc/bus/usb不存在。“
手动进入/proc/bus/这个文件夹查看,却发现只有input和pci两个文件夹,并没有usb文件夹。重启UBUNTU后,现象仍然存在。

在UBUNTU地下能看见U盾的信息,在虚拟XP里面的硬件信息里,也能看见USB驱动下面的U盾信息。

我的VBOX版本是3.1.4 r57640,从官网下载的deb包。


遇到的问题和我一样,我也没有找到是什么原因,只好用root运行以便识别U盾 :em06

请问一下,问题可能出在什么地方?
头像
lexdene
帖子: 434
注册时间: 2010-02-21 16:19
来自: 大连
送出感谢: 1 次
接收感谢: 2 次
联系:

Re: [已解决]Vbox里USB KEY的问题

#14

帖子 lexdene » 2010-05-18 15:59

留名。
它说我留言内容过短。
头像
xclidongbo
帖子: 98
注册时间: 2008-09-06 21:32
送出感谢: 1 次
接收感谢: 1 次
联系:

Re: [已解决]Vbox里USB KEY的问题

#15

帖子 xclidongbo » 2011-04-19 21:56

:em04 我也解决了,呵呵。
回复

回到 “虚拟机和虚拟化”