当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 8.04安装VB无法正常使用。
帖子发表于 : 2008-04-30 13:04 

注册: 2007-04-09 20:40
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
出现很多人说的以下问题

VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Please install the virtualbox-ose-modules package for your kernel, e.g. virtualbox-ose-modules-generic..
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).


返回 代码:
0x80004005
组件:
Console
界面:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

重新安装时发现这个问题。

* No suitable module for running kernel found.


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-30 14:23 
头像

注册: 2007-11-24 20:39
帖子: 112
送出感谢: 0 次
接收感谢: 0 次
和受限网卡驱动一个道理,uname -r确认你的内核,在新历德里寻找对应你的内核的VB驱动安装就可以解决


_________________
http://janzx.blog.ubuntu.org.cn/


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-30 14:29 
头像

注册: 2007-11-24 20:39
帖子: 112
送出感谢: 0 次
接收感谢: 0 次
附图,检索virtualbox,把画红圈的地方用鼠标拖一拖,就看清楚了


附件:
Screenshot-新立得软件包管理器 .png
Screenshot-新立得软件包管理器 .png [ 30.97 KiB | 被浏览 1184 次 ]



_________________
http://janzx.blog.ubuntu.org.cn/
页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-30 17:06 

注册: 2008-03-30 10:35
帖子: 439
送出感谢: 1
接收感谢: 0 次
janzx 写道:
附图,检索virtualbox,把画红圈的地方用鼠标拖一拖,就看清楚了


这是不是还要安装旧内核?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-30 17:58 
头像

注册: 2007-11-24 20:39
帖子: 112
送出感谢: 0 次
接收感谢: 0 次
gong 写道:
janzx 写道:
附图,检索virtualbox,把画红圈的地方用鼠标拖一拖,就看清楚了


这是不是还要安装旧内核?

非也,终端里输入uname -r后会显示你的现在使用的内核,例如我的是-desktop:~$ uname -r
2.6.24-16-rt
我就在新历德里安装 virtualbox-ose-moudules-2.6.24-16-rt
就可以了


_________________
http://janzx.blog.ubuntu.org.cn/


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-04-30 19:08 

注册: 2008-03-30 10:35
帖子: 439
送出感谢: 1
接收感谢: 0 次
janzx 写道:
gong 写道:
janzx 写道:
附图,检索virtualbox,把画红圈的地方用鼠标拖一拖,就看清楚了


这是不是还要安装旧内核?

非也,终端里输入uname -r后会显示你的现在使用的内核,例如我的是-desktop:~$ uname -r
2.6.24-16-rt
我就在新历德里安装 virtualbox-ose-moudules-2.6.24-16-rt
就可以了


你这样就已经安装了新内核了,而且会出现问题。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-04-30 19:16 

注册: 2008-03-30 10:35
帖子: 439
送出感谢: 1
接收感谢: 0 次
大家注意了,那个模块不能安装rt的。 安装virtualbox-ose-moudules-2.6.24-16-generic的。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-05-01 6:14 
头像

注册: 2007-11-24 20:39
帖子: 112
送出感谢: 0 次
接收感谢: 0 次
gong 写道:
大家注意了,那个模块不能安装rt的。 安装virtualbox-ose-moudules-2.6.24-16-generic的。
我觉得自己说的不是太模糊,我说的是我的情况,我uname -r显示我的内核是rt的所以选择安装了vb的rt驱动。别人的情况,清楚自己内核的直接找相应的驱动安装就是了。
不过,像我这种菜鸟小白,喜欢经常捣鼓,更换内核,有时自己也会忘掉,所以最好是先uname -r确认一下再安装。


_________________
http://janzx.blog.ubuntu.org.cn/


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-05-01 10:53 

注册: 2008-03-30 10:35
帖子: 439
送出感谢: 1
接收感谢: 0 次
janzx 写道:
gong 写道:
大家注意了,那个模块不能安装rt的。 安装virtualbox-ose-moudules-2.6.24-16-generic的。
我觉得自己说的不是太模糊,我说的是我的情况,我uname -r显示我的内核是rt的所以选择安装了vb的rt驱动。别人的情况,清楚自己内核的直接找相应的驱动安装就是了。
不过,像我这种菜鸟小白,喜欢经常捣鼓,更换内核,有时自己也会忘掉,所以最好是先uname -r确认一下再安装。


但是大部分人都是generic的,有些人安装了rt以后就不知道怎么卸载了。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-05-01 23:27 

注册: 2007-10-14 0:11
帖子: 274
送出感谢: 0 次
接收感谢: 0 次
我在Virtual Box中安装VB6老是提示无法读取光盘里的文件,这是怎么回事?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-05-02 0:36 

注册: 2007-10-14 0:11
帖子: 274
送出感谢: 0 次
接收感谢: 0 次
现在可以了,10的问题自动解决了.解决方法:重启.


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-05-28 10:37 

注册: 2006-09-08 18:57
帖子: 115
送出感谢: 0 次
接收感谢: 2
sudo apt-get install virtualbox-ose-modules-`uname -r`

sudo /etc/init.d/vboxdrv start


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-08-01 10:16 

注册: 2007-05-18 10:32
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
新利得现在还没有20内核的virtual,等吧


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-08-01 12:03 
头像

注册: 2007-05-08 16:26
帖子: 2058
地址: 火星内核某分子内某原子核内
系统: arch
送出感谢: 20
接收感谢: 6
这么早就在用20的内核了啊?我还在用18的内核呢


_________________
笔记本 :
F208S : gentoo
A460P i3G D6 : UBUNTU + WIN7
UN43D1 : UBUNTU + WIN7
1000人超级QQ群 LINUX + WIN : 31465544 或 18210387


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译