当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 如何8.04下安装官方下载的VMPlayer
帖子发表于 : 2008-05-09 22:31 
头像

注册: 2007-10-09 12:59
帖子: 38
地址: BUAA
送出感谢: 0 次
接收感谢: 0 次
在我用的源里面没有vmware player,于是跑到官方网站上面去下载了一个。
但是在安装程序编译vmmon modul的时候出现了编译问题,提示找不到bitops.h所引用的一个头文件

在这个论坛上面查了一下没有找到答案,最后在英文论坛上面找到了解决方法。这里贴出来希望能对遇到同样问题的人有帮助

在官方的vmware player包的头文件里面包含了错误的头文件,所需要作的是把那个错误的头文件名改过来就行了:
1. cd /usr/lib/vmware/modules/source
2. cp vmmon.tar vmmon.tar.orig
3. sudo tar xvf vmmon.tar
4. cd vmmon-only/include/
5. sudo vi vcpuset.h
6. change line 74 from: #include “asm/bitops.h” to: #include “linux/bitops.h”
7. rm vmmon.tar (return to the folder where you decompressed the tar file)
8. sudo tar cvf vmmon.tar vmmon-only/
9. sudo rm -rf vmmon-only/
10. sudo vmware-config.pl

原始链接:
http://communities.vmware.com/thread/13 ... 6?tstart=0


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-13 21:48 
头像

注册: 2008-03-17 21:37
帖子: 260
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
很强悍,我也是要装VMPLAYER的,但下载了就不知道怎么办了,如果能有从头开始的更详细的步骤估计像我这样的菜虫才能解决呀!


_________________
爱生活,ichaochao......


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-13 21:52 

注册: 2008-05-13 16:12
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我在电骡上下载了这个VMware-workstation-6.0.3-80004版本的,安装没有问题
是不是小版本号的问题呢?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-15 8:31 

注册: 2007-09-02 14:05
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
Nice
用这种方法解决了


_________________
Believe I will be //


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译