当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 弄了一天了也不行 vmware tool 在线等
帖子发表于 : 2008-05-17 19:56 

注册: 2008-05-17 14:57
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
装好UBUNTU后再装vmwa re tool时出现问题了,整了一天了也不行啊,具体问题如下。

参考帖子里面博客的步骤,先解压文件到桌面,进入vmware-install.pl所在的文件夹,然后输入:sudo ./vmware-install.pl ,出现终端提示让输入密码,输入的过程中没有任何提示信息,但是当我输入完密码并且按了回车后终端就消失了。连续做了几次都是这样的。
到底怎么回事?????


页首
 用户资料  
 
2 楼 
 文章标题 : [建议]主机中装ubuntu,然后用虚拟机装windows
帖子发表于 : 2008-05-23 10:58 

注册: 2006-01-06 22:55
帖子: 556
送出感谢: 0 次
接收感谢: 0 次
确保极其简单的安装好vm tools
:lol:


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-23 12:21 
头像

注册: 2007-10-21 16:41
帖子: 1289
地址: GD
送出感谢: 0 次
接收感谢: 0 次
楼上的方法不错。。。。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-26 19:19 

注册: 2008-05-23 20:33
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我也遇到类似情况,但出了password后输什么也不出东西了。
直接按回车后出现sorry,,try again。
请帮帮忙。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-27 9:23 

注册: 2007-10-23 14:09
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
引用:
我也遇到类似情况,但出了password后输什么也不出东西了。
直接按回车后出现sorry,,try again。
请帮帮忙。

linux下为了保密输入密码时是不显示星号的,你尽管输入密码好了。[/quote]


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-06-18 23:21 

注册: 2008-06-18 16:11
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
安照lz的提示装上了,vmware没有再提示“没有装vmware-tools"应该是装上了,安装的时候问了一大堆的问题什么那个文件夹装在那里的烦死了,但鼠标的滚轮还是用不了,不知是那里出了问题。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-06-19 1:18 
头像

注册: 2007-10-21 16:41
帖子: 1289
地址: GD
送出感谢: 0 次
接收感谢: 0 次
以前保存的文档。。供楼上参考。。原作者不详!!

代码:
在Ubuntu下安装VMware-Tools不像在Windows下安装容易,昨晚整了挺长时间终于安上了.方法在下面.



感谢提供方法的大侠!

VMware Tools位置:VMware的安装路径\VMware\VMware Workstation\linux.iso



启动后按Esc选择recovery mode登陆.然后点击"虚拟机"→"安装VMware Tools".



[root@rd01 ~]# mount /cdrom

# 有时可能加载不了,这时就要先将系统关闭,再手动指定 ISO 映像:



[root@rd01 ~]# cd /cdrom

[root@rd01 ~]# ls -a

[root@rd01 ~]# cp VMwareTools-5.5.1-19175.tar.gz /tmp

[root@rd01 ~]# cd /tmp

[root@rd01 ~]# tar zxpf VMwareTools-5.5.1-19175.tar.gz

[root@rd01 ~]# cd vmware-tools-distrib

[root@rd01 vmware-tools-distrib]# ./vmware-install.pl

Creating a new installer database using the tar3 format.



Installing the content of the package.



# 安装过程的画面,全部使用默认值,一直按 Enter 就对了



In which directory do you want to install the binary files?

[/usr/bin]



What is the directory that contains the init directories (rc0.d/ to rc6.d/)?

[/etc/rc.d]



What is the directory that contains the init scripts?

[/etc/rc.d/init.d]



In which directory do you want to install the daemon files?

[/usr/sbin]



In which directory do you want to install the library files?

[/usr/lib/vmware-tools]



Thepath "/usr/lib/vmware-tools" does not exist currently. This programisgoingto create it, including needed parent directories. Is thiswhatyou want?

[yes]



In which directory do you want to install the documentation files?

[/usr/share/doc/vmware-tools]



Thepath "/usr/share/doc/vmware-tools" does not exist currently.Thisprogram isgoing to create it, including needed parent directories.Isthis what you want?

[yes]



The installation of VMware Tools 5.5.1 build-19175 for Linux completed

successfully. You can decide to remove this software from your system at any

time by invoking the following command: "/usr/bin/vmware-uninstall-tools.pl".



Before running VMware Tools for the first time, you need to configure it by

invoking the following command: "/usr/bin/vmware-config-tools.pl". Do you want

this program to invoke the command for you now? [yes]



Stopping VMware Tools services in the virtual machine:



Guest operating system daemon: [ 确定 ]

Trying to find a suitable vmhgfs module for your running kernel.



The module bld-2.6.9-5.EL-i686-RHEL4 loads perfectly in the running kernel.



pcnet32 30153 0

Unloading pcnet32 module



Trying to find a suitable vmxnet module for your running kernel.



The module bld-2.6.9-5.EL-i686-RHEL4 loads perfectly in the running kernel.



Detected X.org version 6.8.



关闭控制台鼠标服务: [ 确定 ]

启动控制台鼠标服务: [ 确定 ]



Please choose one of the following display sizes (1 - 13):



# 显示分辨率,这里是以 1024x768 为例



# VMware Tools 安装的时候,会自动修改 X server 的配置文件



[1] "640x480"

[2]< "800x600"

[3] "1024x768"

[4] "1152x864"

[5] "1280x800"

[6] "1152x900"

[7] "1280x1024"

[8] "1376x1032"

[9] "1400x1050"

[10] "1680x1050"

[11] "1600x1200"

[12] "1920x1200"

[13] "2364x1773"

Please enter a number between 1 and 13:



[2] 3

X Window System Version 6.8.2

Release Date: 9 February 2005

X Protocol Version 11, Revision 0, Release 6.8.2

Build Operating System: Linux 2.6.9-34.EL i686 [ELF]

Current Operating System: Linux rd01.domain 2.6.9-34.EL #1 Wed Mar 8 00:07:35 CST 2006 i686

Build Date: 04 May 2006

Build Host: x8664-build.centos.org



Before reporting problems, check http://wiki.X.Org

to make sure that you have the latest version.

Module Loader present

OSKernel: Linux version 2.6.9-34.EL (buildcentos@build-i386) (gccversion3.4.5 20051201 (Red Hat 3.4.5-2)) #1 Wed Mar 8 00:07:35 CST 2006P

Markers: (--) probed, (**) from config file, (==) default setting,

(++) from command line, (!!) notice, (II) informational,

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(++) Log file: "/tmp/vmware-config0/XF86ConfigLog.3131", Time: Mon Jun 12 20:57:34 2006

(++) Using config file: "/tmp/vmware-config0/XF86Config.3131"

(WW) VMWARE(0): Failed to set up write-combining range (0xf0000000,0x1000000)



X is running fine with the new config file.



Starting VMware Tools services in the virtual machine:

Switching to guest configuration: [ 确定 ]

Guest filesystem driver: [ 确定 ]

DMA setup: [ 确定 ]

Guest operating system daemon: [ 确定 ]



The configuration of VMware Tools 5.5.1 build-19175 for Linux for this running

kernel completed successfully.



You must restart your X session before any mouse or graphics changes take

effect.



You can now run VMware Tools by invoking the following command:

"/usr/bin/vmware-toolbox" during an XFree86 session.



To use the vmxnet driver, restart networking using the following commands:

/etc/init.d/network stop

rmmod pcnet32

rmmod vmxnet

depmod -a

modprobe vmxnet

/etc/init.d/network start



Enjoy,



--the VMware team



[root@rd01 vmware-tools-distrib]# shutdown -r now



# 修改完成之后,重新启动计算机,让 VMware Tools 生效.



==



重启后,你可能会发现还是要按"Ctrl+Alt"释放鼠标(VM6.0没这问题了),因为我用的是5.5.3,所以要手动执行才有效果.

通过终端运行VMware-Tools:

点击Ubuntu桌面左上角的Applications→附件→终端,会打开一个类似Windows中记事本的程序,在里面输入以下内容($是自带的,不用专门输入):



$ /usr/bin/vmware-toolbox



但如果你嫌麻烦,我们就需要让vmware-toolbox实现开机自动运行。点击Ubuntu菜单:System→首选项→会话→Startup Programs,Add一个Name叫“vmware-toolbox”,Command是“/usr/bin/vmware-toolbox”的启动程序。这样每次开机后就能自动运行VMware Tools了。重启Ubuntu看看效果吧!(注意:vmware-toolbox并不是在后台隐藏运行的,启动后不要关闭)。



VMware Tools固然是个好东西,但也有副作用,比如说:虚拟机中的鼠标的滚轮不好使了。我们这样解决这个问题,还是打开终端,输入:



$ sudo gedit /etc/X11/xorg.conf



这个命令使系统以root权限打开鼠标配置文件/etc/X11/xorg.conf。把文件中的



Option “Protocol” “ps/2”



改成



Option “Protocol” “IMPS/2”



重启Ubuntu搞定


_________________
吼吼


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译